hubs and MAC addresses

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View
I'm trying to set up network such as at
but run into some problems. I have several pieces of hardware of which
at least one is giving me a headache, I suspect the hub.  The hardware:

Asus WL-330g ethernet adapter
WiseCOM hub
SMC7004VWBR 802.11b wi-fi router

These are the details for the hub:

"WiseCOM 8-Port 10BASE-T HUB

Compliant with 10BASE-T, 10BASE2 and 10BASE5 specifications of the
IEEE 802.3 standard.

Automatically partitioning function to isolate network failure.

Equipped with a variety of informative LEDs for easy viewing and

MDI-X/MDI selection switch, allowing you to swap the last 10BASE-T
port transmit and receive ping assignments to link your hub to another

easy to instll on a desktop environment

Emission:  FCC Part 15 Class A

Ethernet HUB for Workgroup"

-from the box cover

I start off with the asus WL-330g device connected directly to the
desktop ethernet port, which works fine.  I'm connected to the internet
this way right now.

Next, I connect the WL-330g to the hub, and the hub to the computer,
just like at that picture.  In that situation I can ping the router,
"ping" and also ping google, "ping", or
whatever, with good results.  However, I can't connect to the internet
with a browser.

The tech support guy at Asus has some routers to test this on, and he's
able to connect to a similar router as what I have.  The tech support
ladies at SMC assure me that it's not the router.

Is it possible to somehow test the hub to see if it's working
correctly?  When I leave MAC cloning enabled for the Asus WL-330g then
I'm able to ping everything fine.  When MAC cloning is disabled and the
WL-330g is connected to the hub then I can't even ping the router.

I was reading a bit about how hubs work at
< , and it looks like switches
might handle MAC addresses differently from a hub.  I'm wondering if
this hub isn't handling MAC addresses in a compatible fashion.  Or,
possibly, is doing something totally different to cause a problem.

The manual for the WL-330g states, in section "1.5.2 Ethernet Adapter
Mode" that:

"Multiple IP bridge environment

In a multiple IP bridge environment the Asus Pocket Wireless AP
connects two or more wired devices to a wireless network from
a hub or switch.

You must disable the MAC cloning feature when you set the device
to Ethernet adapter mode under this environment. Enabling MAC
cloning under this environment results to undefined and incorrect
bridge behaviour.

So, MAC cloning is supposed to be disabled on the WL-330g, but I get
better results with MAC cloning enabled.  Could that point to a problem
with how the hub handles MAC addresses?

Would a "managed" hub make a difference?



Re: hubs and MAC addresses

Quoted text here. Click to load it

If you can ping 'google' then you have internet. At that point it's a
problem with your DNS, browser, OS, etc...
When going from the router to the hub you need to use the 'uplink port' on
the router OR use a crossover cable between the router and hub (I think some
routers are auto-sensing, but it's still best to hook it up how it was meant
to be)
I'm assuming that the router is set to DHCP(?) If when you turn your
computer on, it pulls an IP address from the router then it's hooked up

"I don't cheat to survive. I cheat to LIVE!!"
 - Alceryes

Quoted text here. Click to load it

Re: hubs and MAC addresses

Alceryes wrote:
Quoted text here. Click to load it

The SMC tech walked me through changing some settings in IE, I'm
running win2k.

How can I narrow that list, particularly the "etc" part?  I thought it
was a hardware problem as the SMC tech suggested that the hub was at

Quoted text here. Click to load it

It's not a wired connection, but wireless, or 802.11b, or wi-fi,
whatever the buzzword of the moment is.  The router is 802.11b, the
adapter is 802.11g.

Quoted text here. Click to load it

This is what I don't understand.  The tech at SMC said that since I can
connect to the internet then the router is fine.  Right now I have the
Asus WL-330g connected directly to the built-in ethernet port on the
computer and all is good.  However, it's supposed to be possible to put
a hub in the mix.  When I put the hub into the mix, then I can ping but
that's it.

I want to test the hardware, if possible.

The SMC tech seemed pretty sure that it was the hub, but that's easy to
say on the phone.  Can I run sort of diagnostic on the hub, or the
router, to see if they're hooked up properly?  That is, how is "proper"
defined, and can it be tested?

I just want to confine this to the hub for the moment.  It's the oldest
piece of hardware and the only unsupported one, too.  It's also the



Re: hubs and MAC addresses

Quoted text here. Click to load it

Sorry, I didn't read the parts list too closely. I'm guessing that you want
the hub to add another 7 ports to your setup (LAN party?)
Are you saying that when you connect the hub your wireless connection goes
To connect the router to your hub just use a standard CAT5e or CAT6  from
one of the 4 numbered ports on the router to the 'uplink' port on the hub.
Connecting the hub should have NO affect on your wireless connection
unless...hmmm, bad cable grounding the ports maybe? have you tried a
different cable?
Maybe a bad port on the router (or the hub)?
If you have a standard NIC on your computer try disabling the wireless and
connecting to each of the 4 switched ports on the router itself and testing
for internet.
See how that goes...

"I don't cheat to survive. I cheat to LIVE!!"
 - Alceryes

Quoted text here. Click to load it

Re: hubs and MAC addresses wrote:
Quoted text here. Click to load it
Hubs literally do nothing with MAC addresses. They simply repeat what
comes in on one port on the remaining ports -- not quite a passive
device but one which has no "smarts" built in. A switch is a bit more
complex in that it well, switches, rather than repeating blindly.

Presumably you have a broadband modem of some sort connected to the SMC
and to the proper ethernet port otherwise it wouldn't work at all. That
should leave three more ethernet ports on the back of the SMC ignoring
the wireless functions completely and presumably your computer is
connected to one of these three so that you are able to post here. The
computer shouldn't care at all which one of the three you are on. Next
you connect that SMC ethernet port which was working fine with the
computer to the "uplink" port on the hub and then plug your computer
into one of the seven remaining ports on the hub. You should, if the hub
is alive see absolutely no difference between the no-hub and hub
conditions. Does it work with this setup? If so then you've proved that
the hub is alive, or at least the ports you plugged into are working.

Which leaves one really huge question: what is it that you are expecting
the ASUS device to do in your setup? You already have a wireless
connection via the SMC so what is it the ASUS is supposed to add?

John McGaw
[Knoxville, TN, USA]

Site Timeline