Floppy not working on new build?

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View
Got a strange one here that puzzles me.
I know floppies are not much needed anymore, but I would like to know mine
works just in case I ever need it for any reason.

About a year ago I had upgraded to an MSI K8N Neo2 Platinum mb with an AMD
64 bit processor. The floppy I had in it never worked, the light would come
on when you would expect it to, but it would not recognize a floppy was in
it, gave an error to please insert disk. So, I just lived with it.

Last weekend, I upgraded to a MSI K8N Neo4 Platinum mb with an AMD X2 4400
processor. I also got a new floppy drive for it in case my previous one was
just bad.

Everything running well, with the exception the floppy drive again is not
working. New floppy, new motherboard. Same symptoms. Put a disk in and open
it in explorer, the light comes on momentarily, then gives the error message
to please insert disk. The floppy shows up in the bios ( A drive), and is
set to 1.44 mb 3.5" floppy.

Far as I can tell, the floppy cable is installed correctly, the connectors
appear to be keyed in a way to keep from reversing them. I know usually if
they are reversed also the floppy light usually just stays on, and that is
not the case here.

Would appreciate any ideas. It is not that big a deal, just annoys me as I
would like to have it working.  Anyone else ever run into this? Is there an
issue on these MSI Nforce boards with the floppy?

Thanks for any tips,

Don Burnette

Re: Floppy not working on new build?

Don Burnette wrote:
Quoted text here. Click to load it
Try another floppy cable.  Also make sure it is attached to the
connector AFTER the twist.

Re: Floppy not working on new build?

Yep, floppy's are very handy transferring small files or temp files,
or even to get that document to my mate round the corner.

First of all is it being recognised in the hardware  device/hardware
manager...? Is it enabled in bios set up these are the first things
to look at, if it isn't then it's not gonna work.

Can't be nothing serious but rather a setting, are you using the
correct leads,  the correct slot could well be another question.

I'm not too sure but I have a feeling there may well be two types of
signal leads for a floppy a normal and a mirror type may be better to
check this first.


Re: Floppy not working on new build?

Davy wrote:
Quoted text here. Click to load it

Yes, it shows up in device manager and says device is working properly. Bios
recongnizes it as well.

Not sure I understand about the signal leads...


Don Burnette

Re: Floppy not working on new build?


I had the same issue a while back.  I could not get my floppy drive to work
at all, so I replaced it with a new drive.  No problems after replacing.  I
used the same old cable, so I knew that was not the source of the problem.
I know floppy drives are so inexpensive now a days, so it may worth
replacing to avoid further headaches.

Good Luck,

Edward A. Weissbard
El Paso, TX

"Life is easy with eyes closed"
Quoted text here. Click to load it

Re: Floppy not working on new build?

If the bios and hardware manager recognises the floppy, then I'd say
it was installed.

The wires on the ribbon cable are only crimped and wondered if
something like that could be the cause, would make sense to try a new
lead just in case a connection is faulty.

The only alternative is to try a different floppy, have you checked
that they are working properly in device manager? Just had a thought
if they were'nt formatted it would say so asking you if you want to
format this disk..?

Right lets get things in order here-:
You upgraded the mobo, think you can exclude that cos to have two
mobo's with the same fault is asking a little much I'd say.

You tried a new floppy that did'nt work so the old floppy could easily
be OK, pity you could'nt try them in another machine.

The only common question leads us back to the signal lead, just
because the computor is seeing the floppy (bios & device manager)
certainly don't say the lead is 100%.

So what else could it be as everything has been covered..?

Forgot to mention.
If the floppy lead from the mobo is kept flat without any 180 degree
twist all the way to its socket on the floppy it's gotta be the
correct lead, I may have confused the issue a little when I mentioned
the mirror type lead....

Loosin mi marbles thats what it is..!


Re: Floppy not working on new build?

Quoted text here. Click to load it
My guess is that you've got everything right and your new floppy drive is
bad as well as your old one.
I've been through this several times in the past few years. During a 6 month
period a year ago I bought four floppy drives from New Egg. I think a couple
were Sony and another a Mitsubishi and an NEC. One of the Sony's was bad and
so was the Mitsubishi on another occasion. I never sent them back as
shipping-wise it simply wasn't cost effective. And the expression "They
don't build 'em like they used to" is the running line for your situation.
  If you can test your new floppy drive on another system you can confirm

Jan Alter

Re: Floppy not working on new build?

Jan Alter wrote:
Quoted text here. Click to load it

Thanks for all the tips guys, I swear it is the damndest thing I have ever

2 different motherboards, 3 different floppy drives ( 2 of them new), and 2
different floppy cables, and still no go. And I have tried with several
floppy discs. The only common denominator, is both motherboards are Nvidia
Nforce based, one the K8N Neo2 Plat Nforce3, and this one the K8N Neo4 Plat

Ya know, it is not that big a deal as I would rarely have a need for a
floppy, but it is the perfectionist in me that wants to get the dang thing
to work! Maybe I ought to just order an external usb floppy drive and be
done with it!

I may tinker with it a little more. I need to take the side panel off my
case and rework some of my case header connecters, hard drive led is not
working nor is power led, those damn connectors are so small and my eyes
ain't so good anymore, I probably have them reversed... hmmm, unless the
hard drive led connector does not work with Sata drives?


Don Burnette

Re: Floppy not working on new build?

Don Burnette wrote:
Quoted text here. Click to load it
    Is it possible you have something shorting the bottom of the MB while
it is installed in the case???  You might remove the MB and power it up
outside of the case to see if this is possible.  I realize you have had
this problem with two different MB's, but I think I would try it.

Re: Floppy not working on new build?

Ken wrote:
Quoted text here. Click to load it

Thanks Ken, but I really don't think so, everything else is working
I did get the power led light to work, had the connector reversed I guess.
HDD led is not working yet though, I either don't have it on the pins
properly, ( again, my aging eyes),  or it just does not work with a Sata
hard drive ( not sure bout that). Not a big deal either, but again the
perfectionist in me would like it to be functional if it will.

I just cannot get the floppy to work. When I ordered the components to
upgrade, I ordered 2 ea Samsung floppy drives. As mentioned, bios detects
it, Windows XP recognizes it, but it will not read a floppy disc, it is like
there is not a floppy in it. The light comes on to try and read it when I
double click on the a drive, but it says to please insert disc.  I have
tried it with " floppy seek" in the bios set both to on and off.

I'll probably go ahead and order an external usb floppy just to have one
available, and remove the  internal floppy.

Don Burnette

Re: Floppy not working on new build?

What you should do is try booting the computer from a DOS diskette. If
it boots and MS-DOS runs, then the hardware works, and you don't have
to waste time fixing the hardware.

On Mon, 13 Feb 2006 07:36:40 -0600, "Don Burnette"

Quoted text here. Click to load it

Re: Floppy not working on new build?

Quoted text here. Click to load it
6 month
a couple
bad and

Quoted text here. Click to load it

I've never had a new dodgy drive yet, the price of new ones are quite
reasonable and would be a gamble to buy a used one, guess it all
depends on the source and the supplier..


Site Timeline