Error Loading OS after Linux install

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View
I had a home-built PC with a Maxtor 250GB HD running Win XP. Worked
fine for almost 2 years now. The other day I decided to try and install
SuSE Linux on a Seagate 10GB HD that I put in as the slave. Ran through
the install and made sure to do it to the Seagate drive and not the
Maxtor. Restarted the computer and now I get the "Error Loading OS"
If I pull the Seagate drive out and boot I get the same error. Tried
putting the Maxtor drive in as a primary on another computer and get
"Error Loading OS" again. Now Im almost positive the Linux install
didnt format the Maxtor drive but when I put in a WinXP CD and boot to
the repair console, trying to navigate around the C drive just leads to
a "Please insert a disk into Drive C" as if it were a cd drive or
something similar.
What I think happend, although Im not entirely familiar with how Linux
affects the Boot Sector, is that the Linux install changed the boot
sector on my Primary HD (Maxtor) to try and boot linux and now I cant
boot windows. However, when I installed the Maxtor initially I put on a
Dynamic Drive Overlay to boot to the drive (I believe that was because
the drive was bigger than 137GB) and I cannot install that without
formatting the HD.
I would like to be able to restore the Maxtor drive to its original
state but I realize that could be asking for a miracle. So at the very
least recovering some files would be great.
Thanks so much for your help,
Matt D

Re: Error Loading OS after Linux install

Matt wrote:
Quoted text here. Click to load it

When you put Maxtor's DDO, it re-wrote the drive's  MBR to include a
substitute BIOS, which it put on the drives first track.  This BIOS
allows for use of drives larger than 137GB.  (Actually 128GB.)

When you installed Linux you let it install its boot-loader in the MBR
of the drive.  This overwrote the Maxtor DDO.

Quoted text here. Click to load it

Check the Maxtor site.  At one time they had a program to re-install
their Dynamic Drive Overlay.  Using fdisk /mbr will recover a normal
MBR, but it will not work on a drive using DDO.  Don't try it!

There are many programs that will recover data from a drive with a bad
MBR.  For now, do not try to access that drive directly.  Put it as a
second drive in another system, and copy the files to a known good drive.

Good luck!

Virg Wall, P.E.

Re: Error Loading OS after Linux install

I have the original MaxBlast CD and there was an option to Update
Dynamic Drive Overlay. I selected that and the blue banner that says
Maxtor DDO came up on startup. However, it wasnt loading an operating
system like normal. It was asking me for a startup disk to load from.
Also, I tried to install my hard drive as a secondary on another
computer and XP halted on startup. However, I think that could just be
the other computer's fault so I will try another one.

Re: Error Loading OS after Linux install

Matt wrote:

Quoted text here. Click to load it
ask a linux ng, but you've almost definitely f-ed up the grub install. Grab
Knoppix and run the linux partition's grub, and install it to your main

The "making your system bootable" section towards the end of LFS should

poly-p man

poly-p man
There's no place like ~
Help!! I'm being Nibbled to death by cats!!!
"Cardboard is the scourge of humanity, but oh, so very tasty."

Site Timeline