DVD writer problem

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View

I've an DVD writer, Sony DVD RW DRU-190A and an IBM thinkpad R51 with
Windows and Linux FC6. I use a USB 2 enclosure to house the DVD writer
connect to my laptop using its USB ports. Problem is that the drive
doesn't seem to get recognized by windows. I plug the samething into
my desktop and the drive gets
recognized correctly there.

I've had no luck with Linux either, Linux seemed detect the drive
correctly, but didn't
suceed in writing/reading from any disk I put in. It seems to report
the following errors:

kernel: usb 4-4: new high speed USB device using ehci_hcd and address
kernel: usb 4-4: configuration #1 chosen from 1 choice
kernel: scsi2 : SCSI emulation for USB Mass Storage devices
kernel:   Vendor: SONY      Model: DVD RW DRU-190A   Rev: 1.63
kernel:   Type:   CD-ROM                             ANSI SCSI
revision: 00
kernel: sr0: scsi3-mmc drive: 125x/125x writer dvd-ram cd/rw xa/form2
cdda tray
kernel: sr 2:0:0:0: Attached scsi generic sg0 type 5

and then when I try to burn I get:

kernel: usb 4-4: reset high speed USB device using ehci_hcd and
address 5
last message repeated 2 times

The speed detected also keeps varying each time I connect the drive.
Sometimes I get:
kernel: sr0: scsi3-mmc drive: 5x/48x writer dvd-ram cd/rw xa/form2
cdda tray

The errors also vary:

kernel: usb 4-4: reset high speed USB device using ehci_hcd and
address 7
kernel: usb 4-4: device not accepting address 7, error -71
kernel: usb 4-4: reset high speed USB device using ehci_hcd and
address 7
kernel: usb 4-4: device descriptor read/64, error -71
kernel: usb 4-4: device descriptor read/64, error -71

One other strange thing that I noticed was that when I connect the
drive, the USB keyboard
also begins to act strange. Sometimes it just doesn't respond to
keystrokes or keeps giving
multiple instance of a keystroke when I just press it once. I've also
tried unplugging
all USB devices and just having the DVD drive, that didn't work

The drive when connected to a desktop directly to IDE works fine.
When it is connected to a desktop with the USB enclosure also works

Its just that it doesn't work with my laptop. I tried with a another
laptop R52 as well, but that didn't work too. Both windows and Linux
Windows reports that a USB device attached has malfunctioned and
windows is
unable to recognize it. It shows up in the device manager as unknown

The USB enclosure uses USB 2 and has an external powersource.
It gives 12V, 2A. While my DVD writer requires 12V, 1.5A
I use Windows Xp SP2 and Linux fc6 (2.6.18-1.2798.fc6).

Any pointers on what could be wrong would help a lot.


Re: DVD writer problem

Quoted text here. Click to load it

At this point all my conclusions failed. That mean your USB dock is
working fine. Is the driver for this USB enclosure installed correctly
in the laptops?

Can you try connecting your desktops harddisk to the USB enclosure
connected to the laptop and check if it's working fine?

Strider's Profile: http://www.techtalkz.com/member.php?userid=1
View this thread: http://www.techtalkz.com/showthread.php?t=379429

Posted @ http://www.techtalkz.com - Technology & Computer Troubleshooting

Re: DVD writer problem


The problem maybe because power supply is not powerful enough to run
the DVD along with all the devises you have.The laptops just don't
have the power that desktops have.

When you don't have enough power, your devices suffer, that's why your
keyboard acts unexpectedly too. You may check the power consumption of
the DVD and compared to what you have on your laptop.

http://www.powersupplycables.com /

Site Timeline