dma mode

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View

This is the link to a Western Digital 40GB hard drive.  How can I tell
if it supports DMA transfer?

My motherboard IDE controller advanced options is forcing it into PIO
mode and I'm trying to find out where the problem is.

I have a 80GB WD in that computer also and it is in DMA mode.

Any ideas?

Re: dma mode

Quoted text here. Click to load it
Just scroll down to the *performance specifications*
section. The answer is there, yes it supports up to
ATA100 (mode 5).

Re: dma mode

Pen, 4/17/2006, 12:27:15 PM,

Quoted text here. Click to load it

Uhh, thanks for pointing out my blindness!

Now I'll have to figure out how to fix the IDE controller problem.

Re: dma mode

badgolferman wrote:
Quoted text here. Click to load it

The drive might be failing. XP defaults to PIO when there are transfer


Re: dma mode

Quaoar, 4/17/2006,3:57:45 PM, wrote:

Quoted text here. Click to load it

I have changed IDE cables and the problem remains.  I guess it's time
to download the manufacturer's diagnostics.

Re: dma mode

badgolferman, 4/17/2006,6:40:19 PM, wrote:

Quoted text here. Click to load it

I have now tested the drive with the WD's diagnostics and it says
everything is good.  Any other thoughts on how to make this drive
transfer in DMA mode.  PIO feels rather slow.

The last things I remember doing are Windows Updates, Cisco VPN
installation, Oracle 10g which has been uninstalled, Sun One Java
Development kit and installed a new HP inkjet printer.

The only reason I decided to check the setting was because I was in a
Windows 2003 Server Optimization and Troubleshooting class last week
and that was something they talked extensively about.  My machine is a
WXP PRO SP2 machine and I'm rather sure this is a new development since
I have noticed it being slow lately.

I am considering uninstalling and reinstalling the IDE controller
drivers.  Any thoughts on that?

Re: dma mode

I had the same problem with a WD 40Gb, never found a fix. Tried
everything from low level and high level formats, all kinds of
diagnostics, firmware updates, tested it in different computers...
Pretty much everything there was to try I tried. Ended up just tossing
the drive as a spare in my basement HTPC and replacing it.

I've had a couple WD40 gig drives go bad on me though, but I've used
quite a few too. They're getting on in years, and it sounds like this
ones being used in an workstation/server environment which is pretty
disk intensive, so it might be giving up the ghost. For not too much
money you can get a 36.7gb 10k RPM Raptor which'll be much faster than
what you have now.

Is it the 5400RPM or 7200RPM version? I've had worse luck with the

Re: dma mode, 4/17/2006,9:22:55 PM, wrote:

Quoted text here. Click to load it

Thanks to the WXP group, I found the problem.

It seems Windows downgrades the transfer mode as it encounters CRC
errors.  The above site explains the problem and offers a .vbs script
to delete a registry key that has that setting.  Windows remakes that
key at bootup so it redetected the drive and fixed itself.  I figured
reinstalling the IDE controller driver would reset everything but
apparently not.  After backing up registry with ERUNT and System
Restore I gave it a shot.

It is running at Ultra DMA 5 right now and is noticeably faster.  I
will keep an eye on it and see if it degrades again.  If so I will
change out disks.

Site Timeline