Disk Problems?

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View
I have a medium old (2001) Dell Dimension.  My son used it for a
couple of years after I got a new system but eventually it got to the
point where it would boot up (Win 2000) and bring up a desktop but
wouldn't open folders or display files.  I took this to be a disk
problem (although I'm a relative newbie) so on a lark I tried to
reformat the disk and reinstall Windows but after I did that, booting
from the re installation CD that came with the computer, it would go
thorough what looked like the entire initialization process but at the
end I would get a message saying it couldn't find a disk drive.
Thinking perhaps the disk was bad, I bought a new one (160 Gb Maxtor
ATA/100 from Costco) and tried again but got the same message.  I
should mention that the floppy disk drive doesn't work either.  How do
I get the system to recognize the new drive?  Did I just waste my
money when the new drive was perfectly OK (although the extra capacity
is nice).

Any suggestions?



Re: Disk Problems?

madrodger wrote:
Quoted text here. Click to load it

You might just have a bad cable, a bad connection, or have it improperly

Also, something to be cautious about: Your computer may not be able to
properly address hard drives larger than 137GB.  Windows 2000 can, as
long as you're using SP3 or SP4, but both bits have to have that capability.

http://www.48bitlba.com /

What model of Dell Dimension do you have?

Re: Disk Problems?

On Tue, 10 Jun 2008 16:02:11 -0700 (PDT), madrodger

Quoted text here. Click to load it

Do you know what is wrong with the floppy drive?  Do you
have the ability to make a CDR on another system to boot?

Either way, get the hard drive diagnostics from the
respective drive(s) manufacturer website, boot the system to
that and have it check the drives.  

As Grinder mentioned, you might instead have a bad cable and
just flexing the cable a bit (or of course, trying a new
cable) might help.  

It's possible you have a different problem with each,
perhaps the old drive did fail but the new one isn't
jumpered right?  If it is jumpered as Cable Select, try
Master instead.  If jumpered as Master, try Cable Select.  I
assume it is not in the middle of the cable as a slave
device, put it on the end of the primary IDE channel cable
for most compatibility.  I am assuming you have left your
old drive disconnected - if not, leave it disconnected for
further testing of the new drive.

Did/does either drive show up in the BIOS POST enumeration
screen?  If the system doesn't show this, perhaps some
keystroke will show it, or entry into the bios menus might
list what drives were found.  Being a dell it might even
have some diagnostic routine accessible through the bios

If the system is too old to boot a USB drive (it probably is
too old) I would think about getting a working floppy drive
into it.  That is, if it's worth a few dollars to get it
working again and have an alternate way to boot, unless
you're proficient at making bootable CDRs for utility
(diagnostic) purposes.

I wouldn't say the money was wasted, as the old drive - even
if it still works, is at the end of it's expected lifespan
by now and may not life so much longer, plus the new drive
is almost certainly quite a bit faster than the old.

Grinder also mentioned the issue of whether the system can
recognize the whole capacity of the drive.  If the bios
screens show the recognized capacity, note whether it seems
roughly correct, if it shows above 128GB since it is a 160GB
drive.  As a temporary test you might check whether the
drive has a capacity limit jumper, that would limit the
capacity to (usually) 32GB.  If it has such a jumper and you
set it to 32GB limit temporarily and that makes a difference
in it being detected, you have evidence your system won't
support over 128GB HDDs, though sometimes there is a bios
update that will resolve this, and if your board is an OEM
version of an Intel retail board the odds are fair that
intel did release a bios that would support 48bit LBA,
drives over 128GB like yours.

Site Timeline