Dell XPS 8300 christmas morning crash

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View
We ordered an xps 8300. It was received a couple of weeks ago and this
morning when I went to plug it in, I received the message..."reboot
and select proper boot device, or insert boot media in selected boot
device and press key". There is NO operating system disc included with
the boxes, only 2 discs, one a black device driver disc and one, a
grey device driver disc included with the monitor.

I was on the  phone with tech support for at least 2 hrs this morning.
No solution was reached. A tech support is, I hope, scheduled to
contact us in the next couple of days, armed with new hard drives, to
restore the system.

However, because one of the discs allowed me to get into dos mode, I
was able to dir the c drive. It's showing only 36mb with alot of dos
type programs like format, etc. The tech support explained to me the
RAID system being used to address the 2   750 gig hard drives. At one
point, we went to the bios setup and under the advanced tab, system
configuration, , changed from AHCI, to RAID. This still didn't solve
the problem. I can't help thinking that, perhaps the bios needs
upgrading as the tech support kept asking me whether the "RAID" option
I tried was RAID 0 or RAID 1.

Im happy to have the tech support come

 in, but I am equally prepared to flash bios the thing if it requires
upgrade to recognize raid type systems.

Suggestions would be appreciated.


Re: Dell XPS 8300 christmas morning crash

On 12/26/2011 3:32 PM, sw wrote:
Quoted text here. Click to load it
Dell BIOS flashes are found here;

The latest is 06, but it did not address any RAID issues.
Version 05 did not either. Both were only recommended
besides. Your choice of RAID is important since RAID0
makes one 1.5TB disk of the 2 750GB ones, while RAID1
provides redundancy by mirroring the data onto both disks.
It's unlikely that the BIOS is the problem. Dell's norm is
to supply machines with the two drives as separate unless
you requested something else or did something.

Re: Dell XPS 8300 christmas morning crash

Quoted text here. Click to load it

OK. Based on your notes im going to avoid the flash bios option. Bit
of a pain anyways. Thanks Pen. I asked the other gentlemen below but
will ask if you know of a boot repair utility for Windows 7 that could
work with raid?

Re: Dell XPS 8300 christmas morning crash

On 12/26/2011 6:18 PM, sw wrote:
Quoted text here. Click to load it

No I don't. I agree  with others who recommend not using
RAID at all. Also I think you should try the Dell group at for this issue. However, you need to
make clear what you did as regards to RAID.

Re: Dell XPS 8300 christmas morning crash

sw wrote:
Quoted text here. Click to load it


Go back to DOS mode.

The "C:" you were looking at, is the EFI partition.

(I have no idea what it's for, but it was mentioned a couple days ago,
as being in the 40MB size range.)

The other partitions are likely NTFS, and you can't view NTFS from DOS.
More modern versions of DOS, like FreeDOS, would make FAT32 visible for

If you want to poke around your system, try a Ubuntu 10.10 LiveCD.
Boot that, and that can observe NTFS or FAT32 partitions. With
the fdisk command (executed in a Terminal window):

    sudo fdisk /dev/sda

    p                                    # (for "print")
    q                                    # (for "quit")

will give you a review of the partition table.

I think, with a well equipped "CD collection", you'd have that
baby running in no time :-)


There is actually an "NTFS4DOS" program, but it doesn't have
support for Long File Names (LFN). I tried to add LFN support
separately, and that didn't work for me. Which makes the package
rather useless, as the file names will all be converted to
8.3 shorthand, and virtually unreadable. So in name only,
there actual is a way to look at NTFS from DOS. It just
happens to suck...


The Ubuntu LiveCD is a much better bet, as it'll work.

The Ubuntu 10.10 release, is the last one to be
"completely free of the Unity interface". If you got
the very latest version instead, you'd *hate* the interface.
You want to get to the Terminal program as easily as possible,
and Unity doesn't make that easy to figure out.

While the site might not make it easy to find 10.10,
the mirror sites will have it. It won't be too long, relatively
speaking, before support for the repositories for this will be
stopped by Canonical. But you can continue to use the commands
built into the CD.

Going back a level, you can see the other downloads available. /

I just checked the MD5SUM of my copy, and it's the same as
the MD5SUM shown on that site. MD5 is a kind of checksum, and
a (less than perfect) way of determining the download hasn't
been tampered with. I have a Windows copy of "md5sum.exe" for
checking ISO9660 files I download. MD5sum is also available
in Linux, as "md5sum".

59d15a16ce90c8ee97fa7c211b7673a8 *ubuntu-10.10-desktop-i386.iso


What you need, is another PC to prepare that CD for you. A copy
of Nero or Imgburn, can be used to convert an ISO9660 download,
into a bootable CD.

When you stick the CD into the new PC, the boot order will probably
already have the CD first in the boot order. When the screen
eventually comes up, *don't* click the install button. You just
want to use it for poking around.

The "Places" menu, may already shown some partitions on the hard
drive(s) in your computer.

 From the Applications menu, eventually you'll find a copy of the
Terminal program (like a DOS prompt, only with Linux commands).

First, you'd do "ls /dev"

and look for things like this


That would be a disk with three partitions on it.

If you saw right after that


that would be your second disk drive, with two partitions on it.

If you do

    sudo fdisk /dev/sdb

that will access the primary partition table of the second disk.

If you enter "p" as the command, that will print the table.
You can tell from the partition type, what kind of partition
it is. The "fdisk" command has a table of partition values, or
you can consult here as a double check. 0x07 is NTFS, 0x0C is FAT32.
This scheme is hardly precise, as you can see from the history.
In fact, some identifier types overlap enough, to cause damage
when booting alternate OSes.

If the partitions have "labels", the "Places" menu in Ubuntu may
give the partitions easy names to refer to. For example, my
Acer laptop calls the C: partition "Acer" of all things :-)
The second partition on the laptop is called "SYSTEM RESERVED"
and is part of what makes Windows 7 boot. It would be the
active partition, and would have the boot flag set. (Shown as
an asterisk in Linux "fdisk" output.)

Anyway, if you want to play around, that's how you can do it.

One other note - if you do indeed have a Windows 7 C: partition,
*please* don't change files in there. You can look but don't
touch. I've had a few problems fooling around with the laptop,
and had to use the boot repair feature to fix it. I also had to
restore from backup in one case. I don't have a solid recipe yet,
of the "do's and don'ts" for that partition. I'd suggest mounting
the partition read-only (which Linux supports), but Ubuntu doesn't
make that easy for someone new to Linux. They don't even populate
the /etc/fstab file properly any more, so you can't even get a
prototype of what command options would be useful.

My favorite tool for poking around broken PCs, is the Knoppix 5.3.1
DVD, but that would be a much longer download. The Ubuntu one is
bad enough, at 700MB.

You can get reasonably useful Linux CDs down to 200MB in size, and
also use those for repair work. At 200MB though, some things
are going to be missing, and you can't always get the info you
need to get on with the job (like manual pages missing).


GParted, is another way to view disks. It is available as a command
either from the Ubuntu application menu, or you can launch it from
a Terminal window like this

    sudo gparted &

The "sudo" gives admin privileges, the "&" means "fork the command and
free up the command prompt so I can enter another command". You don't
use the "&" thing on the fdisk command above, because that was an
interactive session and you don't want it "floating in space". Interactive
commands should "block" the terminal while you're using them, and that
ensures they have the focus and get the characters you're typing as
their input.

GParted gives you a graphical view of the partitions. It looks much
like Disk Management in Windows, one line of blocks per disk.


I realize that introducing Linux to someone who has never used it
before, is a tall order. But the point of me writing this much, is
to point out there are *lots* of options for forensic work. Virtually
anything else you grab, other than your DOS thing, would likely
give access to NTFS, and tell you what's going on.

If you had an actual Win7 DVD, you can boot that and use the
"boot repair" option, which can fix simple damage cases to the
setup. But since you've got a Dell, and haven't had a chance
to burn any of the "backup discs" they make you burn, you
don't have any recovery or repair discs yet. Which is why
there are always other forensic options.


Re: Dell XPS 8300 christmas morning crash

Quoted text here. Click to load it
# (for "print")
Quoted text here. Click to load it
# (for "quit")
Quoted text here. Click to load it

Thanks Paul. Are the forensic tools you've mentioned above, also able
to act as repair tools?

Re: Dell XPS 8300 christmas morning crash

sw wrote:

Quoted text here. Click to load it

In my previous post, I was suggesting Linux as a means to check what
hardware config is present.

Windows 7 comes with a 200MB repair CD. When you buy a pre-built computer
(like my Acer laptop), the OS will offer to burn that CD for you. But
to get to that point, the computer must be bootable the first time. If
the computer won't run at all, then you won't be able to run off one
of those discs. And the manufacturer is too stupid to include one in
the box. It's not an installer CD, so you can't "steal" anything of
value from Microsoft. And as a consequence, I don't see why it can't be
included with the machine.

That CD doesn't do a hell of a lot. It will attempt to repair the
boot files, if given a chance. It may attempt to run CHKDSK (it
did that on my laptop once, and that took a while). But the
CD isn't clever enough to fix everything.

One web site, Neosmart, was offering a Bittorrent "pointer" to where
it could be downloaded. But Microsoft sent them a cease and desist,
and they took the link off their web site. (There is an archived
copy of the web page, but at this point, it really isn't going
to get you anywhere fast. If you didn't like my Linux suggestion,
you're going to hate the setup necessary to finish a torrent.)


This page has documentation for the XPS 8300.

The Service Manual is HTML based. You download this ZIP and unzip it.
Clicking on index.html should start the manual in your web browser.

The page covering the BIOS, mentions the setting options of disks.


On a normal motherboard, you'd get two things. You'd have

    SATA Mode AHCI; RAID (AHCI by default)

and you could set that to RAID (if you had RAID disks). But the
second thing you'd get, is a "RAID console". Once you save the
BIOS settings, after changing to RAID, on the next startup,
upon entering the BIOS, there is a chance to press something
like "control-I". What should happen then, is a RAID console
should open in the BIOS screen. If the two disks are detectable,
and the disks have RAID metadata on them, then the fact there
is an array present, should be shown in the console. That's
all you'd really want to know there right now, is that
an array has already been defined. If no array was mentioned
in the status screwn, then somebody screwed up the setup

So if you set the computer to AHCI, and it won't boot, then
it might not be "individual disks" and it might be RAID. If
you set it to RAID, and it still won't boot, then no RAID
array of any sort is being detected either. The RAID firmware
in the BIOS, looks for metadata on each disk. That's like a
"stamp" on the disk, that says "I'm the even disk of a RAID 0
speed pair" or "I'm the odd disk of a RAID 0 speed pair".
Since each disk has a unique stamp, you can move them from
one SATA port connector to another, and the RAID firmware
can still determine which disk is odd and which is even.

So again, if this was my computer, I'd want to be able to
access the RAID console in the BIOS, and verify the disks
have been prepared for RAID and "stamped" according to their
role. If the RAID console says "I can see two individual disks
and no array defined", then you know it wasn't set up as RAID.

So even without any kind of CD to use, there are still
questions you can ask of your machine. But to get there,
you need to find the magic key press sequence (assuming
one is available) for a RAID console.

And there is no evidence of a RAID console in the Dell manual.
The thing is, there isn't much consistency in the
key combo used, so while I used "control-I" as an example,
it could be just about anything. (Some retail motherboards
use ctrl-I.)

This article has a few pictures.,1

If the Dell had an EFI BIOS, you might see a screen like this.
You can tell it's EFI, because the mouse works in the BIOS.
Now, I notice in this page in particular, there is no array info
shown. And I don't see any button for causing it to display that
info. Which is a bit strange.

This is a more typical traditional BIOS RAID Console. The
term "Option ROM" at the top, means the code that drew this
picture, is a code module within the BIOS code. The BIOS
code is a whole series of files, stored in a flash memory
chip on the motherboard. Intel writes the RAID Console
code, and a manufacturer buying an Intel chipset, gets
to include that code module if the chipset supports RAID.
In this example, the disks on Port 0 and Port 1, form
a RAID 0 (speed) array, of total size 447.1GB. The
odd stripes of data are on one disk, the even stripes
of data on the other disk.

And that's kinda what I would expect, if your Dell has a
RAID 0 (stripe for speed) kind of setup.


Now, if you had a Linux LiveCD to boot and test, it's just
possible LVM (logical volume manager) would see and grok
the odd and even disk in the RAID 0 pair, and automatically
set things up so you could browse the partition. That's
what I was hoping to do from Linux, is prove it was RAID
by being able to see files in there. But the BIOS RAID
console is another opportunity to do it, and do it without
any more downloads :-)


Re: Dell XPS 8300 christmas morning crash

On 12/26/2011 02:32 PM, sw wrote:
Quoted text here. Click to load it


do not flash the bios

It's important to know how the machine was originally configured

you will need to talk to someone at tech support who can find that info

and you will need to talk to someone there who knows what the hell they
are doing as you will otherwise compound the problem

If you cannot get satisfaction INSIST on talking to a supervisor...

Re: Dell XPS 8300 christmas morning crash

Quoted text here. Click to load it

As note mentioned, I am getting a visit in the next couple of days
with 2 new hard drives. Got your message on the bios. Any boot sector
utilites that you know of out there?

Re: Dell XPS 8300 christmas morning crash

On 12/26/2011 05:16 PM, sw wrote:
Quoted text here. Click to load it

As I said, if you fool with it, chances are you will just make it worse.

If the machine was setup with a RAID array, you will need to re-create
the original configuration...and if you don't know that , anything you
do will only get you further away from the solution...
that is why I never advise a "home user" to use RAID

Re: Dell XPS 8300 christmas morning crash

sw used his keyboard to write :
Quoted text here. Click to load it

I would have thought the answer is simple. It must be under Dell
warranty, being brand new - don't mess with it, let Dell fix it. If you
mess with it, you /may/ invalidate the warranty.


Site Timeline