Dell Dimension Problems

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View

I have a Dell Dimension 3000 only a year old. It suddenly died, meaning no
power what so ever.
Opened up the side panel, connected the power cord, a green LED comes ups on
the motherboard.  Pressing the power button on, nothing happens. No Power!

Installed a new 400W PSU.  Nothing happens.  Same result with green LED on
on the motherboard but no power.

One strange thing I noticed ! I removed the CMOS battery, and the system
powered up.  the fan and hard drive etc. starts spinning.   Tried the same
(no CMOS battery in the motherboard) with old PSU and system powers up.
Got a new CMOS battery, but same results.

Do not know where to go from here.......

any ideas would be appreciated.

Thanks in advance.

Re: Dell Dimension Problems

Ali wrote:
Quoted text here. Click to load it

Plug the front panel switch in. No kidding. It's the one that's bright blue.

poly-p man

Re: Dell Dimension Problems

The Front Panel switch is already plugged in.  That does not make any sense.
The Computer powers up without the CMOS battery and  there is NO POWER if
you insert the CMOS battery ( even a new one). Do you think its a faulty
motherboard ?

Quoted text here. Click to load it

Re: Dell Dimension Problems

Quoted text here. Click to load it
Try in a Dell group. Maybe someone there has heard of this.  is one such.

Site Timeline