Delayed write failure

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View
So...I built a computer, has an internal 320 gig Western Digital Caviar
320 gig just for storage. It's partitioned into 3 chunks, one 150 gig,
a 100, and a 50; and I have Windows on a seperate Raptor 10k RPM SATA.
When there's too much going on with the drive, too many processing
going, writing to, removing, basically any kind of semi-heavy hard
drive traffic going on, i get something similar to this:

Windows - Delayed Write Failure
Windows was unable to save all the data for the file
(file usually located on one of the partitions, E:, F:, G:)
This error may be caused by a failure of your computer hardware or
network connection. Please try to save the file elsewhere

So I have to reboot for everything to be fine again.
Never experienced this problem before and I've tried several things
like updating my nForce 590 chipset driver, played with the windows
registry to fix the write caching stuff, but that didn't help at all.
I see most people experiencing this problem are using external USB hard
drive enclosures, but mine is internal.

Are there any legitimate hot fixes that will take care of the problem?

Re: Delayed write failure

Quoted text here. Click to load it

But as you failed to say what OS you`re using !.
In the event the above doesn`t help, go to  and type in Delayed Write Failure.
You`ll get plenty of hits.


Re: Delayed write failure

My bad. Windows XP Pro media center.

Been all over google, tried every single thing I saw listed on any of
those hits. No luck so far.

Quoted text here. Click to load it

Re: Delayed write failure

On 15 Dec 2006 06:42:49 -0800, ""

Quoted text here. Click to load it

I'd wonder if you had an intermittent drive data
connector/connection.  What does Event Viewer show? Run the
drive manufacturer's diagnostics.  Return Windows registry
to default values.  Try a separate testbed OS install to see
if the problem persists.

Re: Delayed write failure

"" wrote:
Quoted text here. Click to load it

If you don't have ECC memory I would be highly suspicious a memory
error has occurred in the past, possibly fouling some critical
file.  If you have md5sums stored for all files you can at least
check for such file fouling, but it'll take a while.

Just needing to have such nebulous suspicions is reason alone to
ensure you have ECC memory.  If reloading everything from the
original CDs fixes it it would tend to confirm my guess.

Chuck F (cbfalconer at maineline dot net)
   Available for consulting/temporary embedded and systems.

Site Timeline