Cannot Boot from IDE Optical Drive

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View
I'm working with a machine built atop an Intel D946GZIS.  It's been  
difficult to get an optical disc booted to accomplish a clean installation.

There are relevant setting setting in the BIOS like the boot order, and  
a "Boot from Optical Drive" setting.  I have set them to reasonable  
settings, but it is quarrelsome--only a few discs will boot and it seems  
arbitrary which are acceptable.

The boot menu is achieved with an F10 key.  Exiting BIOS setup and  
attempting to get the boot menu is impossible, as it somehow thinks that  
F10 is still meant for BIOS setup.

I tried with two or three different optical drives, but did not get  
lucking with the disc I was hoping to boot until I put in a SATA drive.  
  The problem is mostly avoided at this point, but does anyone know what  
might be going on with this machine's fickleness?


Re: Cannot Boot from IDE Optical Drive

Grinder wrote:
Quoted text here. Click to load it

It's an "old school" design, with ICH7 Southbridge,
4 SATA ports and 1 ribbon cable interface on ICH7.
Not likely to be any UEFI in the picture.

No excuse for it not working :-)

I don't see a nice BIOS section in the manual, with
pictures of what is in each screen. I trust your judgment
on boot settings.

The Intel chipsets with support for more than four drives,
will have a "Legacy" mode that only enables four ports.
If you were using that, two disk ports on the Southbridge
would behave as if they were dead (only four of six work).
Since some things work on the optical drive, and some don't,
I doubt you're using Legacy mode.


Is the IDE optical drive a modern one ?

I was thinking maybe the drive isn't reading burned discs,
and only picks up the pressed discs. Some of the older drives,
might not like ones you burned at home with a CDRW drive. I
have one drive here (probably from around 1999) that has
trouble with CDs. If I feed it any of my burned discs, it
might not like them. If I feed it a pressed music CD, no
problem with that. And no problem with my Microsoft installer
CDs (pressed originals). I think that drive is no longer
in a PC here, and sits off to the side pretending it's
a "spare".

If you're in the BIOS and do a "Save and Exit", that's supposed
to result in the motherboard doing a hardware reset, after
which pressing F10 should work. Section 3.7.4 of the manual
should then apply. If you "Discard and Exit", that doesn't
do a hardware reset on the motherboards I have here, and
the BIOS then picks up as if it's half way through POST.
You don't get a chance to do the F10 then. But you should
get a chance if you Save and Exit. Or, if you were to
press Reset while sitting in the BIOS Setup screen. I
consider the BIOS to be quiescent enough, to withstand
the reset switch, or switching off the power, without
corrupting anything. (Note that, I don't have an Intel
motherboards here, and Intel does things differently than
everyone else.)

Under the circumstances, using the SATA optical is good
thinking. The fun part, is when the end-user of the machine
tries to do something with the IDE optical. And then you
get the phone call...

Do you have a relatively recent IDE optical handy ?
I have a GH22LP20 IDE on the machine here, and
it's been pretty good. No problems reading
media with that. The only thing it won't
read, are the Memorex CDRWs that erased themselves,
and none of my drives here can read them.


Re: Cannot Boot from IDE Optical Drive

On 11/10/2013 9:30 PM, Paul wrote:
Quoted text here. Click to load it

I'm using Normal mode.

Quoted text here. Click to load it

The first drive I used was a Sony DVD-RW manufactured in 2006.  The  
second and third IDEs were DVD-RWs manufactured more recently even.

Quoted text here. Click to load it

The discs I attempted to boot from were all CD-Rs, burnt by the same drive.

Quoted text here. Click to load it

I have pretty current IDE drives around, but won't sweat it too much.  I  
was hoping to figure it out, but the machines is going to be repurposed  
here as a media station, and won't have much use for any optical drive  
as long as it has network access.

I might check into a BIOS update, maybe there's something squirelly that  
got fixed?

Site Timeline