Can't get inkjet going via USB

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View
Win XP Home, SP1
M'board Shuttle AN35N Ultra

I'm not sure if this a hardware or a software problem. I'm trying to get
a inkjet printer to work using the USB port.


I have a cordless mouse & keyboard running via a USP port. The
 "receiver" is connected to the USB port, and it works.

When I self-test the printer (press and hold the on button and open and
close the door four times), it prints a page successfully.

When I connect the printer, an HP Deskjet 3745 ,
to the USB port that shares a header on the m'board , the light on the
"receiver" goes out. The system also can't find the printer (which means
I can't complete the installation using the program that comes on the
printer's CD. The last part of the installation requires getting in
touch with the printer. I was able to install the drivers by Control
Panel > Printers and Faxes >  Add Printer).

When I use a different USB port, like one of the ones directly on the m'
board, the mouse receiver works normally (light stays on), but the
printer still doesn't work.

I'm thinking maybe something is wrong with the USB ports, and maybe I
can remedy the situation by getting a PCI card with USB ports. Can
anybody offer me direction here?

One other little fact: I got the cordless mouse + keyboard because the
regular  keyboard wasn't working through the normal keyboard jack next
to the mouse jack.

So the printer works; that's not the problem.
I've tried three different cables, so that's not the problem either.
The USB port works for the cordless mouse + keyboard, so I think that's
ok (no?).
Naturally, I've tried turning off and on everything.

||||||||||||||||     Nehmo Sergheyev     ||||||||||||||||

Re: Can't get inkjet going via USB

On Sun, 04 Sep 2005 22:13:00 GMT, "Nehmo"

Quoted text here. Click to load it

Then it's either a fault with the printer itself or the
operating system, not the USB port infrasctructure as it's

Quoted text here. Click to load it

OK, though that doesn't necessarily mean the printer is
working right, only that (that) subsystem of it is.  Odds
are though, that the printer is ok and the OS is the

Quoted text here. Click to load it

Then try another USB port.

Also, check your motherboard for a 5VSB/5V USB jumper. If
it's set to 5VSB, change it to 5V.

Quoted text here. Click to load it

No, do not do that... it'll just make things worse if
anything.  Remove any and all things you've done in this

Quoted text here. Click to load it

Are you using a cable that came with the printer or a 3rd
party cable?  Last USB printer I set up for someone, they
wanted to reuse (from some other device they'd had) one of
those silly cables with a little LED built into each end.
Cable tested electrically continuous but wouldn't allow the
printer to work.  Brought a standard $3 cable and it worked
fine...  avoid cables with "things" in them and try another
cable either way if possible.

Quoted text here. Click to load it

Is it possible you're just jinxed?  ;-)

Have you changed any bios settings?
Does your board have a newer bios available that might
address these problems?  If you had a multimeter you might
try checking the continuity on the port and across any
fuses.  Also check power supply voltage, particularly 5VSB.

Quoted text here. Click to load it

Ok... forgot to mention, that LED cable I'd tried- it's
owner had another brand new one just like it- brand new LED
cable didn't work either, for whatever that's worth.

Quoted text here. Click to load it

Is there any chance of trying this printer on another

You might try unplugging ALL USB devices if possible, then
trying the printer.   Could be you do have a defective
printer- odds are against it but certainly "somebody" has to
get the rare one that's bad.  It'd be good to isolate this
by getting the printer and/or system working 100% first and
then trying them together.

Re: Can't get inkjet going via USB

Quoted text here. Click to load it

    From HP web site--CAPS ARE MINE(UNPLUGGED, etc.): Installation
Caution!   The printer's USB cable must be UNPLUGGED BEFORE PROCEEDING!
Do not plug USB cable in until instructed to do so by the installation

  1.. Create a new folder on the hard drive before downloading the printer

    Suggestion: "c:\dj3740"
  2.. Download the driver to the newly created c:\dj3740 folder.
  3.. Open the c:\dj3740 folder and double-click on the downloaded "exe"
file. Once the files are loaded and driver installation screen appears,
proceed to step 6.    Note: If this screen does not appear, continue with
the next step (step 4) to manually open the screen.
  4.. Double-click on the c:\dj3740 folder to open the folder.
  5.. Double-click on the "setup" file to start the installation program.
  6.. Follow the instructions on the installer screens to complete the
HTH & good luck, s

Re: Can't get inkjet going via USB

- sdlomi2 -
Quoted text here. Click to load it

- Nehmo -
I downloaded the HP Deskjet 3740 Series Setup program Version:,
and ran it. Initially the printer is not connected by the USB cable.
At a point, Setup will produce a brief window which says Please connect
printer now, then quickly another window, Looking for new hardware
appears, and it says…

"Please make sure the printer is connected to the computer and powered may take a few.. ", and there's a cancel button.

I plug in the USB cable (attached to the printer on one end) to the USB
port on the m'board, on the back of the computer. I just used this port
for a camera, and it worked.

Setup never moves beyond that Looking for new hardware window.
Apparently it's not detecting the printer.

If press cancel, the whole setup rolls back. The setup program on the
disk HP v 1.00 provided with the printer acts just like the v
one I downloaded form the HP site.


||||||||||||||||     Nehmo Sergheyev     ||||||||||||||||

Re: Can't get inkjet going via USB

On Tue, 06 Sep 2005 19:25:54 GMT, "Nehmo"

Quoted text here. Click to load it

Things to try;

Newer (or older) nForce2 driver pack (

Temporary clean WinXP installation
    - XP (no SP1 yet)
    - XP (w/SP1)
    - XP (w/SP2)

PCI USB2 card

I'd probably try them in that order, depending on
circumstances (like having a spare HDD or backup method to
easily switch from current to clean XP installation and back

Re: Can't get inkjet going via USB

Nehmo wrote:

Quoted text here. Click to load it

I had that problem with an older HP DeskJet that supported both USB and
parallel ports.  It worked only with USB on one computer, only with the
parallel port on another, even though the printer and computer hardware
were fine.  The problem seemed to be another driver that had been
installed previously, and normal installation didn't help.  I had to
run something like Norton Cleansweep to rid all traces of the
troublesome drivers before the printer would work.    More recently I
had to do this to get a USB flash memory to be recognized by one of
those computers.

Re: Can't get inkjet going via USB

larry moe 'n curly wrote:
Quoted text here. Click to load it

norton cleansweep sounds useful.

does anybody know a way to 'clean(clear out) troublesome drivers' (to
do the same operation that norton cleansweep does) but without Norton?

obviously norton cleansweep did things for your comp regarding driver
cleanouts that device manager couldn't do.

Re: Can't get inkjet going via USB

Nehmo wrote:
Quoted text here. Click to load it

you're not testing the USB ports properly. Try the keyb/mouse in every
USB port.  It may work in one but not another.

Then take out the keyb/mouse,

try the printer in every usb port.

I doubt you'll see diff results when you try plugging them both in
together in different combinations. But try.

If you find that one USB port works well, then you could plug a USB hub
into it.

just to elaborate on what has been said alrady..

I'm no expert. But turn off your comp. And plug the wireless usb keyb
and see if you get a light on the keyb.   If it does then it means your
USB port is being powered by the 5VSB rail instead of 5V.  it's
possible for Ps2 or USB be like that. It's a standby voltage from the
PSU that is on as long as your PSU is on, even if your comp is off.
It's no good if the PSU doesn't support the feature properly - gotta be
2A on 5VSB or something. So, if your keyboard does light up when the
comp is off - proving that it's on 5VSB, then try switching a jumper
on the MOBO from 5VSB to 5V if it isn't already. Note, I've had Ps2
devices lighting up rather than USB, and there wasn't even a 5VSB
jumper. But it was using 5VSB.

If your regular keyb wasn't working in the ps2 port. Maybe that
indicates that PS2 is powered by 5VSB and your PSU wasn't supporting
5VSB properly.

PCI-USB adaptor is worth a try. It's nice to have one

It's very likely that it is a driver issue.  There is a long process

particularly its reference to

Site Timeline