BIOS won't read my second new SATA HDD

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View

I'm trying to install a second (new) SATA WD 160gb HDD to the SATA 2
connector on my Biostar P4VTG V7.8 socket 478 mobo and find that Windows XP
reboots during it's startup (doesn't get to desktop). If new HDD is hot
plugged during normal Windows operation, it freezes so no chance to view in
Disk Management. My existing 2 yr old SATA Maxtor 160gb works fine on the
SATA 1 connector but an unusual clicking noise is heard sometimes so think
it is on it's way out.

After reading Biostar's FAQ, I'd like to update the Bios as a possible cure.
Utility is Phoenix Award Bios V6.00PG, VTG 0806BF.

First a puzzling query: Is there a reason there is no listing in the CMOS
Utility for my SATA HDD? I only see 4 IDE drives listed, the A, B and the
floppy. Yet when scanning drives after the bios loads DOS correctly shows
'Serial CH0 Master' as my Maxtor HDD.

Here's where I'm at on updating the bios:
I've used Winflash to save my existing Bios file to a floppy. I have
downloaded and run the Upbios Utility setup.exe for my board and unzipping
results in the Tseries Update folder. Included is the file bios.exe 1,257kb
file version Thinking that running it will request to save it to
floppy, when I try to run the bios.exe in Windows it errors "not
responding", but I suspect I'm not suppose to run it here).
In order to now update the bios do I save the bios.exe in the Update folder
to floppy and run it in the Bios Update part of the Setup Flash Utility? I'm
a bit hesitant as this may not be the correct exe file and I don't want to
corrupt my bios and cause boot problem. I posted this question to the
Biostar Support 3 days ago but no reply.

Any suggestions?

Re: BIOS won't read my second new SATA HDD

Rob wrote:
Quoted text here. Click to load it

I found BIOS update files here, each of which is 262144 bytes (i.e. a 256KB BIOS
You might check your archived BIOS image, and see if it is the same size.

For each BIOS file, I used my hex editor, to search for the module that supports
the VT8237 SATA ports. The version for all the BIOS files is the same. Based
on this information, I would not expect a BIOS update to fix the problem.  \ROM\SATA\VIA20r231.rom
VTG0704.BF  \ROM\SATA\VIA20r231.rom  \ROM\SATA\VIA20r231.rom  \ROM\SATA\VIA20r231.rom  \ROM\SATA\VIA20r231.rom  \ROM\SATA\VIA20r231.rom

The Upbios package appears to be a Windows flashing tool. There is a main
code module, and then a separate module for Award or AMI that would be
called after the motherboard BIOS type was determined. Since the Upbios
doesn't appear to have an actual BIOS file in it, it probably goes to the
FTP or HTTP site to find a file to download. The program could be hanging
due to a networking problem, or it could be that the software used to probe
the motherboard is failing (Windows security feature or antivirus
software). I'm not going to run the program here, because it'll bomb when
it sees a non-Biostar motherboard. The interface might look like this,
based on some of the icons in the installed program folder.

SATA drives connected to a VIA chipset, if they are SATA II, should have
the "force" jumper installed on the back of the drive. VT8237 might
have a problem if the drive supports SATA II, which is what the
"force 150" jumper fixes.

SATA drives are not hot plug capable with just any driver running. At
least recently, hot plug support seems to exist with AHCI drivers,
and RAID drivers seem to be in the same class. But as far as I know,
a default Microsoft driver doesn't support hot plug.

Have you considered it could be the SATA port itself, or the
cable used, which is the problem ? For example, you could continue
to use one drive, as a test case, and move the single SATA drive
to the other port, then boot into Windows. Does Windows restart ?

Next test case, would be to use the cable that connects to the
new disk drive. If that cable is used with the single working
drive test case, does Windows reboot when that cable is being
used ?

I did find an Award flasher here. This would likely be a MSDOS
floppy based flash tool. But whether it would work, or brick your
board, is unclear. In the old days, the suggestion would be to use
a BIOS Savior (duplicate flash chip), as that allows "safe" flashing.
If you brick the board by flashing it, you could be looking at a trip
to the web site, and ordering a replacement flash chip
from them. The program has a list of command line options, which would
probably show up on the MSDOS screen if you tried AWDFL882 \? at the

AwardBIOS Flash Utility V8.82

In DOS (and with the file extension of the BIOS file changed to .bin),
the command syntax might look like this. You should look at what \?
returns, for more details on what each option does. Or do some
googling on awdflash command line options. This might be an example
of something to type in DOS, after booting a MSDOS boot floppy with
the AWDFL882.exe and Vtg1119.bin files added.

AWDFL882 Vtg1119.bin /py/sn/wb

py: Program Flash Memory
sn: No Original BIOS Backup
Wb: Always Programming BootBlock     (this is the one that increases
                                       the risk of bricking - a bootblock
                                       allows recovery from a bad flash,
                                       in theory, but only if the bootblock
                                       is not erased)

Your board has a VIA chipset. The Southbridge is listed as VT8237CD.

In some ways, the storage interfaces are split into two categories.
The two IDE ribbon cable interfaces (up to four disks) are considered
part of the chipset (which is why they appear in the disk setup parts
of the BIOS screens). The two SATA ports are treated as an "add-on"
hardware device, as if the two SATA ports were on a VT6420 RAID
controller chip. The above named ROM code module, provides INT 0x13
services for the two SATA ports, and handles the SATA disks either as
a RAID array, or, without RAID metadata on them, the disks would be
handled like ordinary SATA disks. (At least we hope so. There have
been some SATA RAID interfaces in the past, that only work in RAID mode.
But you know that isn't true in your case, because your single drive

There may be some messages when POST is running, saying something
about "disks... detected", but there may not be an interface
that tells you a lot about the hardware in the BIOS setup. On some
motherboards, pressing <tab> in the BIOS, will bring up the VIA RAID
setup screen (part of the RAID ROM code), but there would be nothing
in that interface that is relevant to solving your problem. (Maybe
you could look at the drive status screen, but converting your drives
to a RAID array would be a bad thing to do at this point.)

Anyway, try a few more tests first, before going for the flash update.


Re: BIOS won't read my second new SATA HDD

You need to change the jumper settings on the WDC drive to  OPT1 (Enabled)
That's 150 MB/s data transfer speed enabled
Your Southbridge doesn't support SATA II drives.

Rob wrote:
Quoted text here. Click to load it

Re: BIOS won't read my second new SATA HDD

Quoted text here. Click to load it

First, thanks to Paul for the detailed investigation on the Bios. I may
explore it later.

I tried the jumper 5-6 approach and voila - Windows booted okay. Now, I've
partitioned and formated it as drive J:
All working well, so far. Thanks BushTurkey for the resolution!
Next step is to image C: to J:, switch the CMOS boot sequence, verify XP
startup on J:, then change J:to C:, verify again, and unplug the Maxtor and
save it for a failure of the WD (and perhaps re-image once in awhile).
In passing, I tried to use my Biostar Utilities disk that had an OEM copy of
Norton Ghost but had install problem with not having a TV codec (another
challenge with Biostar, but that's another issue). I'm contemplating using
the somewhat controversial Arconis True Image V11 to do the image. Any
comments as to the success for my system?

Site Timeline