BIOS updater refuses to load!

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View

I have an old HP Pavilion 8160, modified with a new soundcard,
harddrive, and power supply. I have been using it pretty much daily for
about 8 years without many problems. However, in the past year or so it
has exhibited some little quirks that I suspect might be BIOS-related.

I downloaded the BIOS updater disk creator from and booted into it,
but before it could do anything an error popped up. It said: "Cannot
flash when memory manager (eg HIMEM) is present!" I know that there is
a himem.sys file in Windows, but the updater floppy boots into DOS to
run. I even got the same error after I used a gparted LiveCD to
completely erase my hard disk (leaving only raw, unpartitioned space).

Does anybody know why I am having this problem, and what I could do to
fix it? I really need a BIOS update. Thanks!

Re: BIOS updater refuses to load!

On 22 Aug 2006 20:28:04 -0700, "dylpkls91"

Quoted text here. Click to load it

Does it really create the whole boot disk or just copy the
bios updater to it, and you still have to format and put
system files on it?

Quoted text here. Click to load it

Himem.sys is a DOS driver, though it may come with Windows
for DOS support.

Quoted text here. Click to load it

Look on the floppy for a file named config.sys
open that file in notepad and delete the line that reads:
then save the file.
It might differ slightly, have a path in it too, but it'll
have himem.sys for sure if it's loading from the floppy.

Re: BIOS updater refuses to load!

dylpkls91 wrote:
Quoted text here. Click to load it

THIS is the proper bios.

The directions for diskette creation apply ONLY to win95/98. If you
don't have access to a machine with those OSes. TRy this to create a
driverless bootable diskette:

Then download and run

to finish the job. You should now have a full fledged bootable bios

Proceed with the remainder of the directions.

Thank you, problem solved!

Thanks to both posters. You solved my problem! I actually followed the
steps in the second post because when I tried to edit the floppy's
config.sys the file was empty.Thank you for your thourough explanations

Re: Thank you, problem solved!

dylpkls91 wrote:
Quoted text here. Click to load it

Glad it works. It's ALWAYS better to try to get firmware/BIOS from the
manufactor if at *all* possible (or don't attempt to update without a
damn good reason). You're taking your machines life into your hands
with third party bioses. It's a GOOD thing driverguide's disk didn't
work. And I've done the "Oops, I have win2k, these instructions don't
work" dance a few too many times myself.  :)

Site Timeline