AMD Athlon LE-1620 BUGGED??

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View

"This processor has a known problem when using early BIOS versions. The
symptom of that problem is exactly what you describe (Media playback
speed is not as expected)".

Is it true or it smells like fake?

Re: AMD Athlon LE-1620 BUGGED??


Quoted text here. Click to load it

The answer is easy - It doesn't matter, just dump
Silverlight and play videos like normal people do.

However, the other answer is no, a particular processor is
not going to cause video playback to be too fast.

Re: AMD Athlon LE-1620 BUGGED??

kony ha scritto:
Quoted text here. Click to load it

Many web sites are starting to use silverlight for their  media contents
like live tv streams and videos.

Without silverlight I can't play those media contents. That's the problem.

Re: AMD Athlon LE-1620 BUGGED??

Floppo wrote:
Quoted text here. Click to load it

That thread does not include a complete problem analysis. We
cannot tell from it, whether Silverlight and that processor
have a problem or not.

You could play with "usepmtimer". You should have the
"CPU driver" installed, downloaded from the website.
This thread discusses setting up a modern AMD processor in

You can also play with affinity setting on the Silverlight
program, if it has a separate entry in Task Manager.

So there are a few more experiments and checks that should be
run, before concluding a "processor is bugged".

Disabling Cool N' Quiet temporarily, would be another test case.


Re: AMD Athlon LE-1620 BUGGED??

Paul ha scritto:

Quoted text here. Click to load it

I already installed the latest driver and I already have the /usepmtimer
option in boot.ini.

Quoted text here. Click to load it

Silverlight has not a separated entry. I tried to change the affinity
for the iexplorer.exe process but the change doesn't produce any effect.

Quoted text here. Click to load it

I tried to install PowerNowDashboard Amd utility but it ends saying
processor not supported. I don't know if my processor supports cool n
quiet technology.

Re: AMD Athlon LE-1620 BUGGED??

Floppo wrote:
Quoted text here. Click to load it

I think your processor is a single core, rather than a dual core.
So the affinity thing in Task Manager, should only have had one
tick box. In other words, that suggestion is a dead end. I thought
the processor was a dual initially, but looked it up on
Wikipedia and it is a single core.

I don't know if this is related to there only being one CPU core.
On the one hand, it means no problem transferring timer information
between cores. So one source of timing problems is removed. But
Cool N' Quiet could still change things. Go to Control Panels
and use the Power control panel. Instead of "Minimal Power", use
"Always On", which should run the CPU at full speed all the time.
Then check the video again.

If you want to monitor the CPU speed in real time, try CPUZ.
This is a Windows program. It doesn't cause enough loading
on the CPU, to cause it to rise above the idle desktop
setting, so if the CPU is normally running at the lower
core clock speed, you should be able to see both states
for your CPU. Your Power control panel would have to be
"Minimal Power" for the CPU to be moving between two different
clock speeds. When using a higher power scheme, such as
"Always On", the CPU should remain at the high clock setting
all the time.


I have another test case for you to run. There is a port of
Silverlight available in Linux. The plugin is called Moonlight.
This is the sequence I used to test video playback in Linux.

1) Boot a Linux LiveCD. This allows testing without any data
    being stored on a hard drive. I used my Knoppix 5.3.1 DVD
    for this test. ( is the main web site for Knoppix.)

2) My version of Firefox was out of date. Using the Iceweasel
    (Firefox with name change) browser on Knoppix (icon at bottom
    of screen), you can download the latest version of Firefox
    for Linux (3.0.7 ?). It is a bzip2 file. Open the home directory,
    using the icon at the bottom of the screen. Move the downloaded
    bzip2 file onto the home directory.

3) Open a terminal window. Execute this to unpack the file. The
    folder "firefox" is the result. Change directory so you're
    inside the new firefox folder.

    bzip2 -c -d firefox.tar.bz2 | tar xf -
    cd firefox

4) Now, you're in the Firefox directory. Exit the Iceweasel browser,
    as you're now going to start the new 3.0.7 browser. Type this
    in the terminal window. The "&" on the end, forks the command,
    so you can use the terminal window for other commands if you

    ./firefox &

5) Firefox 3.0.7 should now be running. Go here next.

    Click the icon, to download the plugin. Firefox will prevent it.
    Use the edit button at the top of the screen, where the error popped
    up, to give the go-mono site permission to load the plugin.

    That is the first step. You can verify the plugin is there, using the
    Tools:Add-Ons menu item. There should be one entry there for

6) Now, for movie viewing, you need a media pack (basic codecs). There is
    a trick to this. If you go to a Silverlight web page with a movie
    on it, a popup will offer you a codec pack. Accept it. The codec
    pack will be stored in a plugins folder. The folder would be
    down in ~/.mozilla , as that is where the dynamic junk for
    Firefox is stored (in your home directory). Now, the problem is,
    the codec pack just downloaded, is 249KB and is the wrong file.
    What happens next, is the browser crashes. You'll need to do

    ps aguwwwx | grep firefox

    to list the currently running processes. The one with a fairly
    large memory allocation, is the one you can kill. It has a process
    ID or PID. Say that pid is 4709 for example. You'd do

    kill -9 4709

    and that should clean up Firefox.

7) Well, now you'd like to get the real codec pack. It is mentioned
    on this page.

    For X86 (32 bit Linux, like my Knoppix CD), it is

    That's right, you're downloading a file for a Linux computer,
    from the Microsoft web site.      2,119,776 bytes

    Put that in the plugins folder, in place of the other file.
    If you use the file manager window, you can move the file
    into place with your mouse. The download would be sitting
    on the desktop by default.

8) Now, it is time to test Moonlight (Silverlight). Some test
    pages are mentioned here.

    This site will play a Silverlight video for you. /

    I couldn't go to the RAI site and play the video
    there, because I'm in Canada, and RAI only plays
    for Italians.

In any case, the movie played fine for me, and appeared
to run at normal speed on my Core2 Duo processor. You
can try this test if you want, to see if the Linux
OS results in smooth video playback, at the correct
speed. If the processor is "bugged", then the video
should be bad in both OSes.


Re: AMD Athlon LE-1620 BUGGED??

Paul ha scritto:
Quoted text here. Click to load it

I tried but the video is still played too fast.

Quoted text here. Click to load it

Oh linux, too hard for me to set up a working live linux with wifi
supporto to donwload FF and Moonlight...

But now you say it, I recently used a live linux cd, Backtrack 4, and I
see during the boot process something about timing and/or bug...

Now I go to see and I let you know.

Re: AMD Athlon LE-1620 BUGGED??

Floppo ha scritto:

Linux reported error during boot process is:

"MP-BIOS bug: 8254 timer not connected to IO-APIC"

I disabled "ACPI APIC support" from bios and then linux boot without the


Windows crashes during boot if I keep ACPI APIC support disabled!

My God...

I don't know if that problem can be connected with too fast video playing.

Re: AMD Athlon LE-1620 BUGGED??

Floppo wrote:
Quoted text here. Click to load it

That is a possibility.

Is this the M2N-MX motherboard, mentioned here ?

In the BIOS, try under "Advanced"

    Plug And Play O/S  [No]

What that does, is causes the BIOS to assign IRQs (interrupt numbers)
to the hardware, so that the OS doesn't attempt to figure it out. The
BIOS is then responsible for setting up the hardware. The [No] value
is what I use on all my computers.

When you do that, then try

    ACPI APIC Support [enabled or disabled]

With APIC disabled (so the system uses PIC instead), IRQs
should go from 0..15 and there would be some sharing. With
APIC enabled, IRQs might typically be seen to stretch from
0..23, with 16..23 being used for things like PCI or add-in
hardware. I think Windows should be able to work, with
both of those settings. I'm surprised Windows crashed.

For ACPI (not the same as APIC) Support, my machines here
typically use ACPI v2.0. None of my machines are modern enough
to support v3.0. ACPI is for power management, amongst other
things. It also defines a lot of tables of information,
passed from the BIOS to the OS.

If that still is not helping, I would check the BIOS
revision, versus the BIOS offered for download and upgrade.
I don't see anything in the BIOS release notes, to suggest
they have fixed your problem.

The M2N-MX manual has several strange settings I've never
seen before (Section 2.4.1 CPU Configuration). I don't
think I can explain what they're for.

One thing that is missing from the BIOS, is a selection
of "MPS spec" with choices of 1.1 or 1.4. That used to exist
on some older motherboards, typically boards with two CPU sockets.
I would expect motherboards remove that setting now, and it is
left at version 1.4. That could be part of the Linux complaint
about "MP-BIOS". I'm not really sure.

MPS 1.4 spec is described here. You'll notice the 8254 timer
is mentioned in the document, but not described in detail. All
it needs to do, is wire up its interrupt signal to the interrupt
controller scheme.

It occurs to me, that with a single core processor, there is
no need for interrupt steering to the cores. That is part
of the structure used by APIC.

There is an IOAPIC article here, and from that, a link to
an Intel document with a picture.

"82093AA I/O Advanced Programmable Interrupt Controller (IOAPIC)"

Page 4 of that PDF shows how interrupts are steered when APIC is enabled.
In the example, there are two CPUs. "Local APIC" would be
inside the Athlon64 X2 processor. The IOAPIC would likely be
part of the chipset. In your case, with only one CPU core, there
is less need for a local APIC. The IOAPIC should still be there
in the chipset.

It should still all be working. My purpose in providing that
diagram, is to show what hardware (emulation) is used when
you select APIC in the BIOS.

This device is what is emulated in the hardware, when APIC
is disabled. This is the PIC, the predecessor to APIC. When
people build Southbridges, they would reference this document,
to tell them how to build a PIC. So modern hardware seeks
to emulate the behavior of Intel specified hardware from long


Re: AMD Athlon LE-1620 BUGGED??

I am Floppo.

Paul ha scritto:
Quoted text here. Click to load it

Yes. I am the author of that thread, Mario Rossi.

Quoted text here. Click to load it

The P'n'P o/s has always been on "No".

Quoted text here. Click to load it

I already installed the latest bios available from for
my cpu and motherboard, "M2N-MX BIOS 1004" "2008/04/02 update", and I
discovered it's the same version I always used till now, v02.58.

Re: AMD Athlon LE-1620 BUGGED??

IlGobbo wrote:
Quoted text here. Click to load it

I have run out of new ideas.

The "v02.58" is not the Asus version. The 1004 or 10.04 would be
the Asus version number. The "v02.58" may be the Award or AMI
version information.

I think your finding of

    "MP-BIOS bug: 8254 timer not connected to IO-APIC"

is significant, and maybe this is some kind of motherboard
issue, rather than the processor itself. Either the BIOS
is doing something it should not, when it detects a single
core processor, or there is an actual defect in the motherboard
itself. Something is not right, with either the timer or
the interrupt structure and the steering of interrupts.

That is about all I can guess at this point.


Re: AMD Athlon LE-1620 BUGGED??

Paul ha scritto:

Quoted text here. Click to load it

It's an American Megatrends bios.

I download the 1004 version from Asus support site, placed on a floppy
disk, booted from dos 6.22 bootable floppy, runned the just downloaded
bios flasher utility and it said something like: flashing, writing,
don't turn off the computer, verifing, ok bios flashed.

Then I rebooted, checked the bios version and it was the v02.58 by
American Megatrends, the same bios version I was using before.

Something wrong in my bios upgrade procedure?

Re: AMD Athlon LE-1620 BUGGED??

IlGobbo wrote:
Quoted text here. Click to load it


    "Full Screen Logo" [Disabled]

in the BIOS. Save and Exit. Then, watch the BIOS
screen when the motherboard starts. When text starts
to appear on the screen (white text on a black background),
press the "Pause" key on your keyboard. That should halt
the POST display so you can read it. Press the space bar,
to allow the POST sequence to continue. It is possible
you'll see the Asus release number listed in there.

An alternative checking method, is to install "Asus Update"
utility, and see if it reads the BIOS release number for you.

Yet another way to read the BIOS version, is to use CPUZ.
Unzip the downloaded file, and then just execute "cpuz.exe".
Under the "Mainboard" tab, you'll find the BIOS release
listed. On my Asrock board, the release number seems to
match the Asrock release, rather than some Award/AMI


Re: AMD Athlon LE-1620 BUGGED??

Paul ha scritto:

Quoted text here. Click to load it

It says:

Model M2N-MX
Version 1004
Chipset MCP61
Date 3/26/2008
Bios type AMI
Bios size 512 K

Re: AMD Athlon LE-1620 BUGGED??

IlGobbo wrote:
Quoted text here. Click to load it

Then your attempt to apply 1004 must has worked.


Site Timeline