ALi USB add-on card srews up FDD

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View

A friend of mine bought a digital photo camera, only to discover that
her computer didn't have any USB ports to plug it into :-) Additionally,
the OS on her box was Win95. It's an old PC based on Acorp 6LX87

So I got a cheap USB card based on ALi chip (sorry, can't remember the
exact chip number right now, but it's the centre card listed at ). I wiped the box with fdisk
and installed Windows 98 SE, along with the USB card drivers that were
supplied by the card manufacturer.

Everything seemed to go fine. The computer recognized the camera and she
could successfully download photos from camera to PC.

However, a couple of days later, she called me and complained that she
can't save any files to floppy. I went over to check, and sure enough,
every time you try to copy a file to floppy you get an error message to
the tune of "the source file can't be read". For the files that already
exist on a floppy, if it is say a .doc file and you try to open it with
MS Word, Word gives an error message "the file cannot be found". Try to
format a floppy, it proceeds halfway through and then hangs with a
message "a floppy is not in drive". Also some disks would display
files/folders with names consisting of unprintable characters or with
impossible sizes, such as 4 GB :-) All in all, a complete FDD hell.

I initially suspected a floppy drive or cable going bad, so I tried 2
different drives and 2 different cables. No difference. Then I tried to
use the floppy drive in safe mode and lo and behold, it worked like a
champ - with the same floppies it had refused to accept earlier! My next
move was to disable everything that was being started via
StartMenu\Programs\Startup and
and boot to normal mode. The floppy drive returned to it's errant behaviour.

In desperation I then pulled the USB add-on card and the floppy drive
immediately returned to normal.

So what should I do next? Get a different USB card (which one?) Apply
some updates to Windows (which ones?). I've already applied all critical
updates from windowsupdate, and there seem to be no driver updates
listed. The motherboard BIOS is already latest.

Any ideas are welcome.

.... When cheese gets it's picture taken, what does it say?

Re: ALi USB add-on card srews up FDD

On Mon, 20 Jun 2005 02:21:30 +0300, Toomas Aas

Quoted text here. Click to load it

Try that USB card in a different PCI slot- even if you have
to move some other card to accomplish it.

See if the card manufacturer (or even better, ALI... their
website) has a newer driver for that... from ALI you'd be
looking for a driver for the USB chipset- write down the
markings on it and compare to what ALI has on offer.

If you buy another USB card, I suggest one using NEC
chipset- they've been the leader in discreet chipsets since
early on with USB2, and thus should also have the most
mature driver(s).

Quoted text here. Click to load it

You could also try diabling any unused features of the
motherboard (like COM ports, some of the old ports that may
logically exist but simply not have connector-dongles
installed, parallel port if the printer uses USB, etc). (or
other card features, for exmple the MIDI port on the sound

There were a few USB related patches for Win98, though today
I don't recall which applied to Win98 (first edition) rather
than Win98 second edition.  For the sake of completeness
I'll list all I found,

Note that when the file name is given, that may allow you to
Google search for the specific file IF it can't be found on
MS's website, OR you can search on MS's site by the filename
or just the # embedded in the filename.  So in the first
file, the number would be (as an example), 253697


"USB Enumeration Problems with OpenHCI Controller on Fast

USB Patch for Win98SE On AMD & Via Chipset

storage supplement update 1394 & USB

I don't know that the three above are "all inclusive",
they're merely those that I found.  Ideally you would apply
them in numerical order, from lowest to  highest as that
usually corresponds to the issuance date.

Re: ALi USB add-on card srews up FDD

Toomas Aas wrote:

Quoted text here. Click to load it

I finally got around to looking at this problem again and I think I
managed to get things working on this machine. The key to success was,
believe it or not, disabling the COM2 port in BIOS. With this port
enabled, the card was using IRQs 9, 10, 11 and 12. After disabling COM2,
it took IRQ3 instead of IRQ9 and somehow this seems to make things work.

I wonder if occupying 4 separate IRQs for 4-port PCI USB card is normal
behaviour, or is it just some weirdness of this cheap card.

Thanks to kony for excellent recommendations.

.... (A)bort, (R)etry, (I)nfluence with large hammer?

Re: ALi USB add-on card srews up FDD

Quoted text here. Click to load it

Thats completely normal and I get that with my ALi USB 2 card (it
uses/shares IRQs 16,17,18 & 19) but IRQs on PCI devices SHOULD be able to be
shared without any problems. I've not had a problem with mine and XP SP2
detects and installs it natively.


Site Timeline