2/3 of HD missing

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View

I bought a WD 320GB ATA100 HD and installed it a few months ago.
Initially I installed it in my main computer and tried to format and
form partitions on it using the CDR. It just would not permit
partitioning - wierd considering that I had done this task dozens of
times from the same CD with no problems. I removed the drive and put it
into another computer where I partitioned it and formatted one
partition. Then I returned this WD to the main computer and was able to
install Win2K on that partition.

For a while after this installation I noticed the unformatted part of
the drive numerous times - in Disk Management. Some time later it
stopped showing that part.

Now I want to format the remainder of this drive and install Mepis Linux
on it. I first did a check disk, thinking it would look at the complete
disk and not just the first partition. It went all the way through and
found nothing wrong that I could see. Now I don't know whether it really
did check the whole disk. I tried SiSoft Sandra and all it found was the
formatted part - about 130GB.

Help to find the remainder of the HD would be appreciated.

Re: 2/3 of HD missing

Quoted text here. Click to load it

how does the bios report the drive?

Re: 2/3 of HD missing

RFR wrote:
Quoted text here. Click to load it

Are you running Win2K SP3 ? It supports >137GB on IDE.

Always be careful with this issue. Don't mix incapable OSes,
with partition structures surpassing 137GB. You're asking
for trouble if you do. If using WinXP, it should be WinXP SP1
or later. If using Win2K, it should be Win2K SP3 or SP4. Linux presumably
has similar issues, but I don't know where you'd find a reference.

Click one of the links here, for a copy of the old Seagate white paper on the
subject. If the hardware was not capable, adding a Promise IDE controller
is a possible way to fix hardware-related support issues (i.e. Ultra133 card).

http://web.archive.org /*/http://www.seagate.com/support/kb/disc/tp/137gb.pdf

Once an OS is capable of handling >137GB, I would expect the slack space
at the end of the disk to be visible in Disk Management. If doing a
fresh OS install, if you "slipstream" in an appropriate Service Pack,
you should see the entire disk offered for partition and format. For
example, with my WinXP SP3 disc, I'm offered the entire 250GB of
my latest hard drive.

Computers manufactured before 2003, may have hardware issues with
48 bit LBA support. So even if you use a recent OS, there could
still be a hardware support issue there. This is an example of
a FAQ addressing the issue.



Re: 2/3 of HD missing

Paul wrote:
Quoted text here. Click to load it

Thanks Paul  - that was a quick response :-)

Quoted text here. Click to load it

This 320GB drive already has SP4. I also run a 700GB SATA drive on this
same machine and it is divided into 3 partitions each over 200GB - no OS
on it.

Quoted text here. Click to load it

Quoted text here. Click to load it

The motherboard is an Intel D845GEBV2 that I bought about 18 mos ago. I
believe this model has been around since 2004. I visited the BIOS on the
computer but could not find any HD partition related settings there.
Presumably WD will have some tools to help this.

Thanks for your efforts.

Re: 2/3 of HD missing

RFR wrote:

Quoted text here. Click to load it

I think that board came from before 2004. In the first document,
the BV2 appears Sept 9, 2002.



There is some info on the 137GB barrier here. Intel
suggests their IAA driver can handle their chips going back
some ways. Normally, I wouldn't use the IAA driver, and I'd
be relying on the Microsoft default IDE driver (PCI space
or I/O space version). The caching IAA driver, may have
the odd issue with things like optical drives.


It is also possible, that some brands of disks, have
downloadable tools, and they may use a DDO for support.
That is a dynamic drive overlay. The disadvantage of
a DDO, is some disk maintenance tools may not understand
a DDO is in place.



I'm not aware of a reference that explains all the issues
at the same time. Most of the articles I've read, only
hint at the side effects, without going into the mechanics
in detail.

48 bit LBA works, by "double pumping" the registers on the
IDE interface. They do two cycles, and transfer two groups
of bits. The format of that information, is different than the
previous addressing format. I was able to find a standards
document that described how it worked. Apparently, the drive
command set also contains commands to help identify large
drives, such that the appropriate addressing mechanism can be
used. But the BIOS/OS stuff, is not entirely clear to me.
On the OS side, the advice kept changing. So I really can't
help with any details there. The Seagate document is as
close as it gets, to a helpful document concerning >137GB and
IDE drives.



Re: 2/3 of HD missing

Paul wrote:
Quoted text here. Click to load it

Many thanks again Paul.

Your information is teaching me not to buy antique mainboards.

I hope you don't mind if I try my find first :-)

From:   http://support.microsoft.com/?kbid=305098

the following is an extract:

"The following conditions are necessary for the correct functioning of
48-bit LBA ATAPI support:

     * A computer with a 48-bit LBA-compatible Basic Input/Output System
(BIOS) installed.
     * A computer with a hard disk that has a capacity of greater than
137 gigabytes (GB).
     * You must enable the support in the Windows registry by adding or
changing the EnableBigLba registry value to 1 in the following registry


To enable 48-bit LBA large-disk support in the registry:

    1. Start Registry Editor (Regedt32.exe).
    2. Locate and then click the following key in the registry:
    3. On the Edit menu, click Add Value, and then add the following
registry value:
       Value name: EnableBigLba
       Data type: REG_DWORD
       Value data: 0x1
    4. Quit Registry Editor."

I had no problems down to the 0x1. I was flying by my pants there and
entered the value data of 0, 1 or 0x1 (there is a choice of binary,
decimal and hex.)

I tried numerous combinations of 1s and 0s and always had the message:
"The Registry Editor could not create the value entry. The value entry
already exists. Please enter a new name."

Trust MS to leave things befuddled.

Strangely enough I remember making numerous registry changes of this
kind in the past and they worked. This time I am hexed.

Help please!

Re: 2/3 of HD missing

RFR wrote:
Quoted text here. Click to load it

It finally accepted a 1 and Hex but a reboot of the drive made no
difference. It is still showing 129GB instead of 320. Maybe the BIOS
needs oiling or blowing up or something like that ;-)

Re: 2/3 of HD missing

RFR wrote:
Quoted text here. Click to load it

Hey Paul,I'm back.

I was side tracked for a while and today I had some success. Here is a
list of the steps:

1    The BIOS Archive for the Intel board showed the latest update             was
7/14/2003 Ver: 08.00.08.
2    The Specs for the 320 GB Caviar EIDE drive indicated LBA             support.
3    I waded through the BIOS and found nothing related to LBA
4    Next I installed the Intel® Application Accelerator.
5    As soon as it rebooted the C drive showed two partitions,             whereas
only one had showed since I installed the HD.
6    Lastly,I downloaded a partition manager - EPM - and will soon         
divide up the remaining 170 GB to give space for Linux and who             knows
what will go on the other partition.

Many thanks again for your help :-)

Site Timeline