IR port locked, can't reset or open! Need ASAP for Palm!

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View
Somebody hepme!  Heh, um, big problem, no idea how to fix it.  I don't
even know what could have caused it because I didn't do anything
differently than usual.  Just tried to hotsync my Palm and it said the IR
port was locked by another process, only there ISN'T another process!
There's nothing showing in the "ctrl-alt-del", nothing in the tray,
nothing even in the background from startup in the registry (checked with
Startup Manager).  It will even do a "search for IR devices in range", and
I can hear the really faint sound it makes go on and off when it's doing
it, so I know it's really not locked and working.  Anybody know what's
going on?  I know it's not the Palm's fault because I have 2 totally
different models and they do the same thing (hence posting here instead of
the Palm groups).  Can anybody think of anything?  I totally depend on my
Palm(s) so I really need to fix it fast!
For email response, or CC, please
Yeah, it's really a real address :)

Re: IR port locked, can't reset or open! Need ASAP for Palm! wrote:
Quoted text here. Click to load it
the IR
range", and
Quoted text here. Click to load it
instead of
on my

Are you trying to do an IR hot sync?  If not, maybe deleting the
IR hotsync modules might help.  Have you tried doing a soft or
hard reset on the PDA?  It sounds like a flag has been set and
won't get flipped unless it is pinged, or the software is reloaded.

Re: IR port locked, can't reset or open! Need ASAP for Palm!

Dear News Subsystem wrote:
Quoted text here. Click to load it
Err...what is the actual error message, and on which device does it

Of the three common error messages, none includes the word "locked":
1. "Error accessing the IR Port.  See the //Helpnotes//IR_Readme.txt for
more information."
Appears on Windows, versions 2000 and later; indicates a local problem.
Won't apply to Windows 95.

2. "Unable to initiate HotSync operation because the port is in use by
another application."
Appears on the Palm, indicates a problem there (see below).

3. "The connection between your computer and the desktop could not be
established. Please check your setup and try again."
Appears on the Palm.

I'm presuming you're experiencing the second.  If so, initiate the
HotSync process (hit the HotSync button) *before* bringing the PalmOS
device into range of the PC.

See question 1.1 etc at my FAQ,

Otherwise it could be an error specific to Windows 95...?

Quoted text here. Click to load it

Have you only recently enabled the "Search for ... devices in range"

Quoted text here. Click to load it

I think its your PC provoking both Palms into a conflicting state.

Given your extreme desire to get this working, you'll be wanting to
reward me it this is solved. :-,)  If so see my wishlist on my homepage.
Alan J. McFarlane /
Please follow-up in the newsgroup for the benefit of all.

Site Timeline