Apache on XP Pro SP2 - who blocks my port 80

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View

I'm having some issues with an apache 2.0.xx server running on a XP Pro
SP2 machine.

My network
Cable modem->router(linksys)->desktop(wired) ( open ports 80, 8080 )
                            ->laptop(wireless) ( open port 8080 )

The apache2 in install and running proper on my desktop at port 80 in
my LAN.

The laptop is visible from outside of the router( internet ) when
people try to connect to it.
It's a different story from the laptop none of the two are available.

I did disable all the firewall software  ( MCAffe that took over the
microsoft firewall )
Actually I have McAffe firewall on the laptop as well, both machines
have fixed IP addresses in the LAN, I could not see difference in the
TCP/IP settings.

Any idea what can be wrong or direction I have to reseach ?

I was planning to install the apache2 on the laptop to see if is
working but I don't yet see why wouldn't work.

Finally I've managed to open 8081 on my desktop and now I see also the
8080 but the 80 is seams to be blocked by someone
- ISP( comcast ) - anyone knows anything about that ?
- firewall (?) - I have mcaffe but I'd exited while testing
- antispyware( microsoft, spysweep ) - I'm uninstalled microsoft-as
still nothing
- the windows firewall ( it's disabled )

I had installed before MS IIS but I've stopped, anyhow the
http://localhost/ is alive and kicking.

I don't see why anyone (software) would block that port number without
letting me know.

I hope it's not my ISP...Anyone knows, does Comcast bloc 80, their
answer is pending...Is there a way to find how blocs port 80 ?

The Q

Re: Apache on XP Pro SP2 - who blocks my port 80

Quoted text here. Click to load it

Hi, I don't know if you've solved your problem yet. Anyway, I had a
similar problem tomorrow and, after inspecting my network's
connections with the "netstat -an" dos command, I noticed that a
program was blocking the port 80 (I got something like TCPIP LISTENING).
The program blocking that port was SKYPE. If it's your case, look at
the configuration window of SKYPE: you'll find that under the
connection tab there's a checkbox that allows skype to listen to port
80 as an alternative. If you uncheck it, you can allow apache2 to
start correctly.
Hope this may help you.

Site Timeline