Problem Buying NOD32

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

I have an interesting little problem, that is truly puzzling (to me).
My system is a thinkpad t40, WinXP Pro, SP1.

If I go to the (or website and click the purchase
link, when I then click on any of the 'buy' links, absolutely nothing
happens.  I've tried clicking with the mouse, both sets of buttons on
the touchpad, and using TAB and pressing enter.  No joy.  This occurs
using Firefox 1.5, IE6, Opera8, Netscape8.1, and portable FF1.5.  I
took the portable FF to another computer and works just fine.  I have
cookies, javascript, java enabled.  I do note that if I copy the link,
paste in the address bar, and remove the non-URL stuff, it brings up
the page.  I've set my firewall (ZAPro4.5.594) to the most lenient
settings, and even shut it down, but no joy.

I had the same problem a couple of months ago, and figured it was just
their website, because a few days later everything worked.  I sent them
a email recently and it works for them.

I've run Adaware, SuperAntispyware, Spybot, The Cleaner, A2, Nod32, and
NAV2003 in safe mode.  No problems found.  Nothing odd in Task Manager
or Sysinternals process viewer that I can see.  Even disconnected the
mouse and reinstalled the touchpad drivers.  Nothing.

Went to some other anti-malware vendor sites and it appears I can
purchase there okay.  Have I left any testing idea untried?

Any help is much appreciated.


Site Timeline