unsolveable syntax error

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View
Problem web page:  http://www.imagedgifts.com/htmls/makeu5503.html

Page seems to look fine but shows error in bottom left hand of screen.

Line: 2
Char: 1
Error: Syntax Error
Code: 0
URL: http://www.imagedgifts.com/htmls/makeu5503.html

Can anybody see what might be causing that error?


Re: unsolveable syntax error

Quoted text here. Click to load it

For a start, what have you done about all the errors mentioned
when checking validators?


Re: unsolveable syntax error

Thad wrote:

Quoted text here. Click to load it

I don't see that particular error message on that page in either IE7,
FF2 or Opera9.


- Your HTML is invalid, defining it as both XHTML 1.0 Frameset to
  begin with, and attemtping to redefine it as HTML 4.01 Transitional
  with a second <head> section inside the <body> tag (which is WAY off)
- Your page triggers the popup-blocker in all three browsers above
- The external Javascripts referenced in the header don't exist
- The images attempted loaded from the select list don't exist
- Some <a> tags point their target to a frame named "_new", but I don't
  see any frames around in your document by that name

There are also several other errors, but I simply won't let my head get
through that until you've fixed all the above errors (especially the
first one; producing a page with at least somewhat-valid HTML and a
consistent DOCTYPE), since that bit in particular is giving me a
headache (in a somewhat less manner than as administered by a Microsoft
Word/Publisher/FrontPage-generated tag soup).

Kim André Akerø
- kimandre@NOSPAMbetadome.com
(remove NOSPAM to contact me directly)

Re: unsolveable syntax error

Soup it is, but it worked.   I created the file in arachnofilia and
everything seemed to work.  There is also a validator in arachnofilia which
said "no errors". Sorry that my LACK of programming knowledge showed.  What
really hurt was thinking I was doing so well to get it running but with one
unsolveable syntax error...or so I thought.  After I posted this first
message, I went to validate the page at WC3 and was shocked at what I saw
was wrong. I want to say thanks for those who took a look at the page and
how embarrased I am on letting the page be seen with so many errors.  Back
to the drawing board.

btw, the only error I can dispute was not having the image files on the net.
Not that I didn't want anybody to see them, I just tried to save time by not
uploading them.

Thanks again for all your help.

Quoted text here. Click to load it

Site Timeline