Unable to Validate at w3.org

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View
Odd... I'm not sure why my pages are unable to validate at w3.org. I
have the header placed in there but get the following error message
for the site:


I added the following at the header:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"
"http://www.w3.org/TR/html4/loose.dtd ">

and get the error message below:

I was not able to extract a character encoding labeling from any of
the valid sources for such information. Without encoding information
it is impossible to validate the document. The sources I tried are:

The HTTP Content-Type field.
The XML Declaration.
The HTML "META" element.
And I even tried to autodetect it using the algorithm defined in
Appendix F of the XML 1.0 Recommendation.

Since none of these sources yielded any usable information, I will not
be able to validate this document. Sorry. Please make sure you specify
the character encoding in use.

Re: Unable to Validate at w3.org

jeff wrote:

Quoted text here. Click to load it

It tells you why.


David Dorward                                      <http://dorward.me.uk/

Re: Unable to Validate at w3.org

shakeme@yahoo.com says...
Quoted text here. Click to load it

<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">

Hywel     I do not eat quiche
http://hyweljenkins.co.uk /

Re: Unable to Validate at w3.org

On Sun, 14 Dec 2003 20:40:56 -0000, Hywel Jenkins

Quoted text here. Click to load it

Many thanks... sometimes you look things over a thousand times....

Re: Unable to Validate at w3.org

Quoted text here. Click to load it

"meta http-equiv" is only an ersatz. That's why it's called "equiv".
http://ppewww.ph.gla.ac.uk/~flavell/charset/ns-burp.html explains
the difference to you. See also

What's the most irritating thing on Usenet?

Site Timeline