Problem with Frames website

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View
I administer a fairly simple website, which uses
Frames. It works pretty well, except that occasionally, for example if
one visits it after visiting , clicking on a
link in the lefthand 'contents' opens the subpage in a whole page,
instead of as part of the page. Any Ideas? (apart from giving up
Frames altogether!)
TIA Nick

Re: Problem with Frames website


Quoted text here. Click to load it

Yes, it did that for me, too, and (surprisingly) in both IE and Firefox.

I don't know specifically what's wrong but the markup is archaic and in
some cases invalid by modern standards.  There is no DTD, putting browsers
in "Quirks".

The best way to fix it is to use a strict doctype, update the page to
currently-acceptable markup under that doctype, and then validate the
result at the w3c.

Infinity can have limits.

Re: Problem with Frames website

Quoted text here. Click to load it

You need to look at your use of "target" in your code. It looks
wrong to me: <frame name="contents" target="main" ...

I used to use target only in the links themselves and had no
trouble. try removing this from your frameset. Leave the target
for the links in the actual source code of the frame itself.

Your code is bad, validate it, put this at the top of your whole
html doc:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Frameset//EN"
   " ">

then go to a validator like /


Site Timeline