Netscape 7 oddity

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View
So I have a PHP script that displays a picture and then goes on to the
next one, for the sake of a survey.

Now, the code works fine in IE 6, NN 4 (how can anything work fine in NN
4, you may ask, but it does).
However, in netscape 7.1 or whatever the latest one is,
it only displays the lower 50 pixels of the pictures...

I can't wrap my mind around what could possibly be the problem...
the code is here:

I know its set to hidden, but the script changes it to visible.. once it
becomes visible, only the lower 50px show...

Any ideas?

<table width=640 border=0 cellpadding=1 cellspacing=0>
<tr><td colspan="2" align=center>
<span name="mtest" id="mtest"
style="visibility:hidden;position:relative; font-size: 20px;">
<img src="pics/mpic.jpg" onLoad="javascript: var timerx =

Re: Netscape 7 oddity

Ed Vul wrote:

Quoted text here. Click to load it

Without seeing the whole page code or an url, it's impossible to figure
out the reason for the 50px differential.
I note that you do not quote all your attribute values and I recommend
doing that. Also, writing "javascript:" in your onload event handler
achieves nothing.

Have you checked the markup of your whole page with a validator?

Javascript and Browser bugs: /

Re: Netscape 7 oddity

After a long and grueling session of deconstructing my code (which was
CSS validated) it turned out that netscape was getting screwed up
because the overarching SPAN had a position:relative; whereas the Image
had no position declaration.. setting image position to relative fixed
the issue.

I hate netscape.


Site Timeline