frames and forms

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View
Working with frames for the first time, I have found that when I put a
little form in the left frame, and then use it, it causes the regular
hyperlinks in that frame to forget to open up in the right frame.

Here's the steps:

1. Click any link in the menu on the left frame. The links are regular <a
href-type hyperlinks. They are set to target="rightframe"   which is the
name of the right frame.  It works fine.

2. Just above the nav menu, there's a little form with just a text box and
submit button. Type the criteria into the textbox, then hit the submit
button. It causes the right frame to display the desired page with desired
information. It does not reload the left frame.

3. Now, click any link on that left frame's menu. For an apples to apples
comparison, click the same link that was clicked in Step 1. It brings the
correct page, but in a new browser, which also happens to be missing the
left frame.

Is there any known issue with forms and frames that I am not aware of?

For the record, this is in IE only, as it's Intranet and 100% of users are
on IE.
Also, because it's Intranet, I cannot show it to you.

Re: frames and forms

middletree wrote:
Quoted text here. Click to load it

Can you not strip your code down to the bare minimum and post it online
somewhere.  Odds are it's a fault in your code that you're too close to
see, but without seeing it...


Site Timeline