: disable WAP browser caching

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View
Hi All,

(Apologize if I got the wrong list, this was the closest fit I could
find. Kindly do redirect to the right list if possible)

 I am trying to disable the browser cache on a Treo 600 running Blazer
browser v3.0. I am generating the wml page using JSP and I have added
all the header/meta tags I can find to disable caching on the browser
but it still continues to fetch the page from the memory and does not
disable caching. I notice that my refresh in wml gets the page from
cache (<go> </go> command) whereas using the browsers built in refresh
menu option gets the latest page from the server. So I had two

1. Help :) how do i fix this. I am reproducing my code segment below.

<?xml version="1.0"?>
  "http://www.wapforum.org/DTD/wml_1.1.xml ">
response.setHeader("Cache-Control", "must-revalidate, no-cache,
max-age=0, forua=true, no-store");
response.setHeader("Pragma", "no-cache");

2. Is there any way I can access the browser menu options using

Much thanks in advance for any help.


Re: : disable WAP browser caching

amar.groups@gmail.com wrote:
Quoted text here. Click to load it

I'm afraid your problem is browser-related rather than
anything else.
Try also setHeader("Expires","0");
If you're really into headers, see also the http rfc:

Site Timeline