css problems (wrong group prob)

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View
well I've posted around in a few forums

http://inversedesigns.superihost.com/test /

is my site, it works perfectly in IE, but in FF it seems to totally render
it differently, however it used to be sort of the other way round, but to
over come this

in the main id a div, which is the white area with the title New's

I added

#main {
    width:100% <---- that bit


the reason was that the tables which are being displayed have a width set
too 100%

I am really confused how this works differently in FF and is their anyway to
over come this problem,

any advice at all would be apreciated.

Re: css problems (wrong group prob)

Quoted text here. Click to load it


You should also use a doctype that triggers "standards" mode.

Quoted text here. Click to load it

Looks better in Mozilla 1.7.5 than IE6 here. What exactly is it that you
are trying to fix?

BTW: Why are you only using half the width of my browser?


Mark Parnell

Re: css problems (wrong group prob)

inverse wrote:
Quoted text here. Click to load it

Blurgh! You're using a combination of browser-sniffing and Javascript to
set the table width? Please don't do that! What if I don't have
Javascript enabled, or I decide to resize my window?

And your HTML is completely screwed. You have a load of TABLE and DIV
stuff before your HEAD section. Run your page through
http://validator.w3.org and fix all the errors before you worry about
why it's not working.


Site Timeline